Incorrect IDs added to species after Android App Crashes


App version number: 1.29.1


Screenshots of what you are seeing: included below

Description of problem:

Wrong IDs added to species after android app crash:

Last night I was adding some species to a new to me project.

This was done by using the explore feature and searching a genus and region of Minnesota. Additionally filtering by username “GuidingGuida.”

I then was scrolling through the observations to the left and right, clicking edit and adding the observation

to a specific project and obscuring the location. Occasionally scrolling one observation to far into a observation for a different species than the ones I wanted to add to the project. This included Scottish Asphodel, Butternut and 12-13 other species.

This was fine until I tried to do observation for Moose. Every time I tried to add an observation of moose to the project, entering the edit part of the observation would cause the app to crash.

This morning I received a message from another user that the linked observation above which had two different, and wrong, species ID added to the observation.

They were the last two species I edited observations of before the app crashed.