iOS app tends to crash to home screen since updating to iOS 15

I have this problem too. iOS 15 on iPhone 11 Pro Max. The “seek” app still works.

I have the same issue, updated to iOS 15, app v: 3.2.2 running on an iphone X.

Since the update, I’ve not been able to open it once as it crashes as soon as I try to open it. Have tried to delete and reinstall and the same problem persists.

Same issue, iPhone XS.

Platform: iOS 15.0, iPhone XS

App version number: 3.2.2

Description of problem:

Step 1: try to open app

Step 2: watch it crash immediately on the “updating database…” page.

Step 3: repeat until the very rare time when it actually stays open.

2 Likes

Welcome to the forum! I moved your post to this existing report. Hopefully there will be a fix soon.

2 Likes

OK, we have a potential fix for this issue in the latest beta release, 3.2.3, and it would be really helpful if at least some of you can test it out for us and let us know that version runs on your device.

You can join our beta testing program by going to https://testflight.apple.com/join/Hk9r2NJj on your device. You’ll have to download Apple’s TestFlight app from the App Store.

1 Like

The beta resolved this issue on my iPhone 12 Pro Max. Thanks!

2 Likes

I’m having the same issue with my iPhone 11 Promax. It keeps on crashing.

We’ve gotten positive feedback from beta testers who were previously experiencing this crash so we’ve pushed version 3.2.3 out to everyone in the App Store. It should be available within the next few hours or by the end of the day (California time). If you update, please let us know if this fixes the crash.

There are a few known bugs in 3.2.3 related to the header (sometimes it will display in black, as below) and will work on a fix for that next. Shouldn’t really affect functionality, but if it does please let us know in a separate bug report.

1 Like

Update 3.2.3 appears to have fixed the crashing for me.

1 Like

Great! And you’re able to make observations, use Explore, etc?

Everything seems to have been working fine so far after the update, just tried uploading an observation and it seemed to work.

1 Like

I’m going to close this bug report, so far it looks like this has solved the instant crashing issue.

2 Likes