Need info! iOS app crashes when you tap on photo library icon in iOS 13

Hey everyone,

We’ve been getting reports from some users that the iOS app (version 2.8) crashes when they tap on the photo library icon in the new observation screen

This looks to be happening to those who have updated their device to iOS 13 or 13.1. Unfortunately, no one on the iNat team has been able to replicate this on our devices, so if this is happening to you, we’d love some information to help us diagnose the issue. If possible, can you please share:

  • which device you are using
  • which version of iOS it’s running
  • a screenshot of iNat’s permissions (go to the Settings app, then scroll down to iNaturalist and tap on it. It should look similar to this:

  • send us a screenshot of your iCloud photo settings. You can find these by going to the Settings app on the phone then tapping on your user icon at the top, then tapping on iCloud. It should look similar to this:

Here are instructions for how to take a screenshot:

If you don’t feel comfortable sharing that information here, you can email it to

Thank you!

1 Like

I think this only happens if you have already used the app a bit (e.g. submitted some observations, made IDs, etc.). Certainly the app slows way down and then crashes after making a certain number of IDs on your own observations. EDIT: for clarification, this is when you go into the observation and edit the ID in the observation title, not add a new one through the “comments” section.

1 Like

I just got a new iPhone 11 that is running iOS 13.0 on Monday, and I am experiencing the iNaturalist system crash if I try to upload a photo from my library. INaturalist does work without crashing if I take the photo in the app.

1 Like

Thanks, and I’m sorry you’re experiencing this. If possible can you please provide the screenshots asked for the initial post here? We need as much information as possible to investigate the issue.

I have this problem, but the app crashes when I try to choose a photo from my photo library, not when I tap on the photo library icon.

I’m using an iPhone X running IOS 13.1, and the latest version of iNat (2.8).

The app crashes when I select photos that were taken with my previous iPhone (an iPhone 7 that was running on IOS 12.3 I think) but it runs normally without crashing when I select photos that were taken with my new iPhone X.

1 Like

I’m having the same issue. Tapping the photo library icon immediately crashes the app.

Device & iOS details…

  • iPhone 8 Plus
  • iOS 13 and iOS 13.1 (originally had the issue under iOS 13; just updated to iOS 13.1 and still having the issue)

Requested screenshots below.

If you need any additional information or need beta testers for the fix, please let me know.


iPhone 8, just updated to 13.1 and it’s still happening.

And I don’t use iCloud for my photos

iPhone XR
Dark Mode

Thanks for the responses, everyone, they’re really helpful.

Someone who wrote into about this yesterday says the app is now no longer crashing when they tap on the library icon. It would be interesting to know if that’s happening to you as well.

Again, I apologize for this bug. The information definitely helps us track it down, however.

It is still crashing for me. I tried deleting and reinstalling the app and turning off the phone, but the problem is still persisting. :(

Has anyone else tried this?

I don’t even use iCloud and I’m getting it. I’ve turned on iCloud and changed that setting, it’s still doing it.

I tried deleting google photos which is what I use to archive/back up photos and it still is doing it.

1 Like

Thanks for the info, @manticore, I’m sorry you’re being hit by this still.

Looks like Apple is releasing another update to iOS 13: If anyone updates to this version and it fixes the import photos bug, please let us know.

Just updated to 13.1.2, fresh install of the app and shut down phone, still crashed every time. :(

Like am I the last one left with it for whatever weird reason?

Something else that comes to mind, I can use my photo library with Seek. No idea why but maybe it’ll help.

1 Like

It is still crashing for me too after updating to 13.1.2.

1 Like