Issues moving and zooming in/out on map in location selection in web observation upload page

last night, i added my first bunch of observations in a month or so (via the website), and i noticed that when i went into change location manually on some of these observations (during the initial upload process, not in edit mode after the observation was already uploaded), the maps were behaving a little strangely. if i click and try to drag the map around either by touch or by mouse, the map moves only one notch and then stops. i can notch it over little by little, but that’s annoying. this happens in either Edge or Chrome. i also noticed in both Edge and Chrome that touch/pinch zooming doesn’t work on this map. mouse scroll zooming works in both Edge and Chrome (as does clicking the + / - buttons).


I can replicate in FF, we’ll take a look.

Exact same behaviour for me in Chrome, basically totally unable to move on the map,

1 Like

It may be that I just never noticed this before, but the tile boundaries are on the map now, I never remember seeing those before, so it may be some kind of issue with the tile server / services ?

I’m getting this too, Windows/Firefox

Thanks folks, we’re working on a fix.

I’m also having the same problem using both Safari and Google Chrome browsers. I’m unable to drag across the map with the mouse, but can do it with the arrow keys, albeit more slowly. After plotting a location correctly and pinning it, when I go to the location the map defaults to showing somewhere in Libya, while when you zoom out to see the whole planet, you can see the red circle correctly plotted still (in this case, over in Arizona).

This was brought up here: And in testing the potential fix for the slow maps issue, I’ve found that the pinned location issue also seems to be fixed. We’re planning to deploy the fix soon.

Sorry about this, I removed the weird 45-degree tilt view a day or two ago and apparently the way I did it messed up panning. We just released a fix for this a few hours ago. Is it still broken for anyone?


looks like my issue is fixed. thanks.

1 Like

It looks like fixing the map moving issue brought the weird 45 degree view back. Bummer too, what a major annoyance that is.

wasn’t that just about making the tilted view the secondary aerial view by default (instead of the primary)? that’s what i see – so it seems right to me.

Yeah, I’m seeing what @pisum is seeing, so I think this is working as intended. @schoenitz, if you’re seeing something different, please include a URL and a screenshot.

1 Like

When I tried manually adding a location in the uploader at the time of my last post here, the map switched to the 45 degree view as I zoomed in.

But when I tried again just now, it no longer does that. The vertical view sticks at any zoom level. Hooray, and thanks!

ok. everyone’s happy! time to close this!