Licenses not updated using new account settings page

Platform: Website (today Chromium on Manjaro Linux)

Howdy,
new to the site, mostly to be able to discuss/contribute the occasional ID I suppose, but uploaded two observations with an image just to earn credit to be able to message an observer who’s email address I lost.

Anyway: On upload, no questions about licensing were asked. Turns out the default license is CC-NC-ND or some such. ND sucks big time for a default license, but that’s beside the point. So I’m off into my account settings to see if I can change the license settings. Sure enough, so changed everything to CC0 - the only license that actually truly allows other people to do useful stuff with your work.

Ticked all the boxes for “update license on existing images/obs/whatever” and saved the settings

No such luck. Observations and images are still presented as CC-NC-ND or whatever.

Tried again. Same (non) result.

So there it is: The tick boxes for “update existing” under the licenses seem to be disfunctional.

Cheers, Arp

P.S. Hmmm … on review, licenses now show CC-BY-NC … pretty sure I read ND in it before (as it upset me). Issue might be that the requested CC0 is substituted by BY-NC ?? Confused …

2 Likes

Okay - went to one observation to see if I could change the license there. Yes.

  • Changed the license on the obs. (via the Edit drop down menu) and ticked the boxes for “update previous”
  • Went into the photo info page and changed the license + ticked the boxes.

Now the license is properly updated as well as on my other observation/photo, but via the “Account Settings” this did not function.

Hi, welcome aboard! I’ve just looked at your two observations, both the photos and the observation are now licenced CC0. Might have just been a slight delay before the system updated them?

1 Like

Ah, ok. posted that as your second comment came through

Howdy lawnranger,
might be we just crossed our actions (see post above yours).
I’ll try changing to something else and back via the Account Settings to make sure

Changed to CC-BY via the account settings now.
But everything is still indicating CC0
I’ll leave it be for now and check back in a few hours to see what gives …

I think it’s fair to assume that this is not a “may take a while to sift through” issue.

  1. Changing the license on obs/photo and ticking “update past …” works

  2. Changing the default licenses in Account Settings and ticking “update existing …” does NOT work

I have fixed it for my obs/photos by using option (1), but the bug report as such stands.

Cheers, Arp

The default should be CC-BY-NC.
The account settings page redesign was released literally yesterday, so it’s to be expected that there’s still bugs to iron out.

I think there is a prompt on mobile to choose your license when you sign up, but not sure… it’s been a while since I signed up. There isn’t on the web browser, which may be an oversight.

As mentioned, it takes time for observations to be reindexed. One way to force them to do so is to add an ID (you can withdraw or delete it afterwards).

Can you please see if you can reproduce the issue?

2 Likes

In order to prevent spam/phishing, new users have to have either 3 verifiable observations OR 3 IDs for others before sending messages. You shouldn’t need to create observations to meet this requirement.




As Blue said, the default is CC-BY-NC. There is a whole topic about it here if you want participate in the discussion.



That’s not entirely true. The web signup looks like this:

And clicking Learn More by the check box gives you this:

image

It’s explained that the default is CC-BY-NC, and by unchecking the box, you can switch to All Rights Reserved. The other licensing options are available after logging in for the first time.





As for the bug, I can confirm that when I use the new account settings page to change my default license and check the box to update previous observations, the previous observations do NOT have their licenses updated.
I modified the topic title to clarify this is in the new account settings page.

5 Likes

Welcome to the forum

2 Likes

Related (or the same as) this issue I think: https://forum.inaturalist.org/t/new-account-settings-page-shows-copyright-settings-reset-to-cc-by-nc/19433/

That problem had a different cause and should be fixed now.

1 Like

Thanks to all for taking the time to look at this! (Hi Optilete! :grin: )

Okay, so I must have misread the default license somehow - my bad(!) Good thing there isn’t a ND in it :upside_down_face:

thr_blue is correct in that there is some talk on permissions while signing up, but it is just a general “I agree my stuf is used” without a choice of specific license at that point.

Coincidence that I stumbled on the bug in a crackingly new interface page the day I signed up - had no idea it was new of course.

Glad the bug could be confirmed. Not a big issue as I could change things via the other dialogs but still good that it has been recorded now.

Thanks & respect to all the people building and improving this site!

Cheers,
Arp

1 Like

This bug should be fixed now, I was able to quickly change licenses to existing observations on my test account.

Fix confirmed. Functions as advertised now - thanks for fixing it!