Long-term web search link is no longer updating for last few weeks

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About): n/a

Browser, if a website issue (Firefox, Chrome, etc) : Firefox

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/observations?captive=false&place_id=27595&quality_grade=needs_id&iconic_taxa=Aves,Amphibia,Reptilia,Mammalia,Plantae

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): I have the above URL as a shortcut to start my iNat every day, multiple times a day, for over a year. The last few weeks it has not been showing many new observations in my geographic search area and I thought things were just slow. Then once in a while it would refresh and I would see new records. So I started trying to force a server refresh by slightly changing the search terms to “sort by observation date” instead of “sort by posting date”, but that didn’t always show new records. Today I realised it was a problem on your end when it won’t even show me my own new observations after I have just posted them, after just observing them. My observation is listed when I choose “My observations” but not when I switch back to the search URL that has worked flawlessly for many, many months.

Step 1:

Step 2:

Step 3:

Is this an obscured place issue? It looks like a lot of your observations are obscured. If they fall outside the place boundaries, they might not show in the search.

1 Like

I just added an observation there (will delete soon) and it showed up in that search:

I note that your URL only includes observations that Need ID - is that intentional?

1 Like

this particular place is a county-equivalent “standard” place in the system. so theoretically, obscured observations should still be captured within the place as long as the true coordinates fall within the boundaries, even if the public coordinates fall outside the boundary / bounding box.

this is a case where screenshots of what you’re seeing would really help other people understand / see exactly what you’re experiencing. without screenshots or a video of exactly what you’re doing, it could be hard for folks to do anything to help you.

a couple of examples of observations that aren’t showing up for you would help others help you, too.

2 Likes

Have you tried clearing your browser’s cache?

I find that clearing the cache has never worked. It is frustrating when that, followed by switching to Chrome, are the default advice.

No. I can’t figure out how to balance the needs ID vs the other ones.

I can try but I’d have to have a backup screen shot to compare to when and if the update finally happens. IIUC

No. I’ll try that.

But it’s always worked until now. Although now always always. Chrome. Darn. No can do. Too freaked out. But thanks for the point.

1 Like

I’ve cleared the cache but not of cookies.
One image is on initial link click (inatscreenbeforesortedupload)
Then I change the sort to date observed (inatscreenbeforesortedtime)
Then I go to my obserations and you see my new observations.
I got back and refresh multiple times but the link nor refreshes bring my new observations into the view.

Thanks for all your help. I’ve fallen behind in computers in the last 10 years so I appreciate your help and patience.



No. Firefox is fine.

1 Like

all but the Crossbills observation in your last screenshot are research grade. the link in you original post will get you only needs ID observations, which is why only the Crossbills observation shows up in your results. if you want to return research grade observations, too, you need to use a different link, such as: https://www.inaturalist.org/observations?captive=false&place_id=27595&iconic_taxa=Aves,Amphibia,Reptilia,Mammalia,Plantae

i assume this means you don’t know how to select both research grade and needs ID observations using the Explore page’s filter interface. it can be a little confusing because that interface uses binary checkboxes to try to represent filter options that are really ternary / trinary – for example, (1) explicitly filter for research grade, (2) explicitly exclude research grade, (3) get both research grade and not research grade (implicitly). (when that trio of options are mapped to a binary checkbox, then checked = explicitly filter for research grade, and unchecked = don’t explicitly filter for research grade.)

i skipped the filter interface altogether and modified the filters in the URL directly, but if you want to use the filter interface, then since the Verifiable box is checked by default (Verifiable = Needs ID + Research Grade), you can uncheck both the Needs ID and Research Grade boxes in the filter interface to get both Needs ID and Research Grade observations. (the interface does not allow you to check both boxes.)

that said, i don’t see an actual bug here even though the filter interface is not perfect. this thread should probably be reclassified as a general discussion.

2 Likes

Agreed, at this point, we can determine that it isn’t a bug, so I’ve moved to General.

It seems to work to uncheck both verifiable and research grade boxes. I see all my observations now, including ones that are not (yet) research grade. Thanks a million.
It sure seems like a bug to me to have it work like that, but whatever. I’m happy to get it to work. No program logic aligns perfectly with every user’s thinking.

1 Like

I wasn’t seriously advising that. But tech support reps do frequently advise that – I believe that is the reason Chrome has become the most widely used browser. The mystery is what the support reps get out of it, since I doubt that Alphabet is paying them to say that.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.