Observation both has a location and a location missing

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Edge

URLs (aka web addresses) of any relevant observations or pages: https://inaturalist.ca/observations/124833839

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: went to Link to observations (with photos) that are missing locations. from the Frequently Used Responses. Found observation https://inaturalist.ca/observations/124833839

Step 2: Advised observer that observation was missing location.

Step 3: Observer added location, but map frame still displays “Missing location”. Tried different browser window (in private), same error.

1 Like

“Locality notes” is a separate text field from the GPS location on the map, so people can sometimes enter the location but not actually put the pin on the map. If they put their cursor in that text box and press enter or click “Search”, it should search for the location and plot it on the map. Or they can manually plot a new pinpoint by zooming into the map.


But it’s not showing “missing location” when I look at all the user’s observation page either:


Is that screen showing location notes as the location column?

The screenshots I shared are from the Edit Observation page.

The observation you linked to is missing the pin icon unlike the others in your screenshot. (edited to reflect new screenshot).

I don’t know why it would be missing. It’s the same observation, as you can verify from the date/time observed & the image.

I just mean your second screenshot here confirms the location is missing from that specific observation (I see nothing unexpected), as opposed to the other observations depicted. The casual observation is listing the Locality Notes–without the pin icon which indicates map location added.


Ah, I see. I thought my second screenshot shows the location present, but there’s no pin by the “address” there.

Thanks, @bouteloua !


This topic was automatically closed after 15 hours. New replies are no longer allowed.