Seek does not open camera

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website):
iOS 17.0.2 i
App version number, if a mobile app issue (shown under Settings or About):
2.15.0 (310)
Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1:
Click on Camera icon in Seek
Step 2:
App goes to home screen and apparently closes Seek
Step 3:
Another approach: Click on Continue Challenge
Then click on Open Camera
Same result. Closes Seek and goes to home screen

Apple’s not giving me the option to update to iOS 17.0.2 yet, but the app works fine on 17.0.1 for me.

  • what camera permission does Seek have?

  • do you know approximately how many Seek observations you have?

  • can you send log files from Seek after the crash? You need to be signed in to an iNat account in Seek to do so. Then go to the About page and tap on the version number.

  1. No permissions show up for Seek in camera
  2. I don’t have any Seek observations because when I clock on camera icon the app closes
  3. The log file shows nothing of interest. I just has multiple lines stating the app version

Having the same issue on a new iPhone.

Sent in the debug email.

I just tried on my old iPhone with 17.0 and it works. So has to be something with either new iphone or 17.0.2

Thanks. Looks like 17.0.2 is only iPhone 15 phones, so I can’t update to it. It looks like the library we’re using for Seek’s camera is getting reports from other apps that are seeing the crash in iOS 17.0.2, so hopefully a fix will be available soon.

I have an iPhone 15 Pro and iOS 17.0.2 and Seek crashes instantly when I click the camera icon. Tried deleting and reinstalling Seek but that did not help.
Hopefully there will be a fix soon!

Would anyone be interested in testing out a potential fix by joining the Seek beta testing program?

Yes, I’d be more than happy to give it a try on latest iOS / iPhone 15 Pro.

Great, thanks! You can join the Seek beta program here: We don’t have a beta version to test yet, but you should get a notification when it’s available.

1 Like

Awesome, joined I’ll watch for the next build to come out.

1 Like

I would be happy to.

1 Like

Thanks! Please sign up at the link I posted above.

I just downloaded and tested the new beta, version 2.15.2. On my 15 Pro Max running 17.0.2 it now works. It no longer crashes when I tap the camera icon. I will continue to test other functions.

1 Like

This update has been released to the App Store.

1 Like

This topic was automatically closed after 20 hours. New replies are no longer allowed.