Seek not always inviting me to post to iNaturalist

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): iOS

App version number, if a mobile app issue (shown under Settings or About): 2.13.6 (243)

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: open Seek by iNaturalist

Step 2: open the camera and wave it at some plant until it suggests a species

Step 3: take the pic and click “post to iNaturalist”

Step 4: click “ok”

Step 5: click the camera icon to open the camera again

Step 6: wave the camera at something until it suggests a species, then take the pic

Doesn’t offer option to post to iNaturalist.

I don’t think it happens every time. Restarted the app usually brings the option back.


I have this exact same issue, but on Android rather than iOS. I’ve found that, after the first observation, I’m able to use the back button in the app to back all the way out to Seek’s home screen, after which I’ll be able to submit to iNat the next time I use it to ID something. I have no idea if/how that will translate to iOS.


Similar/same behavior for me.

Platform: iOS, iPhone 11 Pro
App version: 2.13.6

My first observation after opening Seek goes normally, including replacing image if it’s one I’ve seen before. After submitting to iNat, I get the prompt about updating the image again, but this time both the old and the new image are the same since I have already replaced it.
Backing out to the camera, the next observation will ID fine, but will not have an upload to iNat button. I have (reluctantly) worked around by quitting and restarting the app, I have not yet tried going all the way back to the home screen as mentioned.
This behavior has been consistent for the past few weeks as I’ve started getting out in the spring; I did not have any issues with sequential observations last year. At least for me it has been happening every time.


Made a bug report here:


@tiwane I don’t have a GitHub account, but I am experiencing the identical behavior. If you want to add the info about my device, it is:

Android 11
Samsung Galaxy S10e
App version: 2.13.6 (243)