Seek Not Posting to iNaturalist

I have thousands of observations made with Seek. Within the last month or so, I notice that when I go to post to iNaturalist, it shows me ‘posting in background’. In the past, this has been successful. Sometimes, it has required a nudge when I am back on a wifi network to “post uploaded to inaturalist” by relaunching the app. But now when I do that it still fails to post to iNaturalist. Sometimes 1 will go through and Seek just perpetually says uploading 1 observations even when I quit out of the app and reopen it.


Could you please fill out the provided bug report template with the requested info so that it’s easier to diagnose the problem

Not posting from Seek Bug Report

Platform (Android, iOS, Website): iOS

App version number, SEEK: 2.15.3 (316)
iNaturalist: 3.2.15 (it appears truncated so I can’t see what comes after)

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

  1. Take photo. Click on the button to post to naturalist. Click through the criteria to confirm post. Click ok to post in background.

  2. When I come back to Seek Home it continues to show upload. Sometimes it says done, but most frequently it just shows the attachment even when there is nothing left to post


What happens if you go to a different page (eg Achievements) and then back to the Home page? There’s a known bug where the uploader graphic doesn’t update unless you do that.

I’m noticing this too now that you mention it. Have only tried to upload like 2 things from Seek over the last few days so it didn’t really click that they hadn’t been posted. Just tried to upload an observation from Seek and can confirm it does not make it to iNat.

I’m having the same issue. In my case there are several observations that I’ve tried uploading from Seek, and none have been posted to iNaturalist since 10/5/23. Seek always says “Uploading 1 observations”, even though there should be more than 10. I tried closing the app, turning off and on my phone, and repeatedly refreshing. Going to a different page also doesn’t work.

1 Like

Thanks, I can replicate (although I don’t ever see an on-screen graphic saying Seek is trying to upload anything) and I’ve made a bug report:


I still use the beta version, and I can’t upload via SEEK since about last weekend… - First I thought, I had missed to send them… but just now I rechecked, I can’t upload, it doesn’t show the green bar of uploading or an error. It just says, it will load it up, and it just doesn’t… sigh

I tried to open the debug report, hitting the button shows no reaction… so I can’t provide data…

I have the same problem since 3-4 weeks. Lost a ton of observations. It happens regardless of having a good connection or not. I tried to kill the app, reestablish the iNaturalist link. Nothing works unfortunately.

Also while checking challenges, they all have green dots like they have notifications or like they would be “new” challenges. But actually they are all completed

In addition, trying to load nearby species for a challenge it fails with the error “We need the Internet to generate…” despite internet connection working great

Looks like quite some bugs / regression slipped in … At this point the app is not really usable anymore, unfortunately…

My version is the same:
Platform: iOS 16.7
App version number, SEEK: 2.15.3 (316)

I’ve been using the app for years and even though it has some long time annoying upload bugs, when you killed the app in the past, and reopen, it will continue to upload.

With this version, no upload happens or even shows as pending / in progress.

1 Like

@tiwane - The github issue you mentioned above seems from May 2023 and is about iPhone backup. The issues reported here seem to be new, from October, and different. Unless there is a connection between the bugs

Apologies, here’s the bug: And I updated my post above.

1 Like

And Android 10 with the beta 2.15.3

Fingers crossed, that it can be fixed easily…

I was having this issue in October 2023. Solved it by downloading the iNaturalist app and changing my password. I only had the Seek app with a linked iNaturalist account but I didn’t have their app.

Once I logged in to the iNaturalist app, I returned to Seek and tried uploading the observations that were failing. They uploaded within a few seconds.

I’m pretty sure this is because your account’s email address wasn’t confirmed by September 6th, and was only confirmed when you reset your password. That being said, it’s interesting that you can upload Seek observations now. Which version are you using?

As for me and not beeing able to upload:

I just checked, if I had missed a SEEK update, normally it should do that automatically… and yes!!! End of September update wasn’t done!!

Just did it and tried uploading…

It is working again!!!


1 Like

@ tiwane - Thanks for the updated bug link. The steps to reproduce that bug are absolutely correct.

Unlike all the issues reported on this thread, at least myself and @ dmarymac, we have the latest version for iOS so there is no magic update to pull and fix the issue.

Also, some people see the hanging “Uploading x observations…” message. As you rightfully noted in the referenced bug, in my case I see no indication of uploading or any hanging “Uploading …” message after I click on “Post to iNat”. Simply nothing happens and the observation is entirely lost.

I tried in different locations, even different countries, with different mobile networks or Wifi networks, the behaviour is the same. It just doesn’t work anymore.

The iNaturalist app works, with the same location and connection, if I post the observation directly from there.

Relinking the iNaturalist account to the Seek app didn’t help either.

At least in my case, I am in dire need of a bug fix and waiting for an new update


1 Like

I hope, the bug get’s fixed for you…

I didn’t have hanging uploads, too… they had just disappeared, too.

Same for me. Not the end of the world really since uploading through iNat isn’t a big issue, I just like the friendly layout of Seek for a quick and easy post.

1 Like

The bug is back for me… sigh

All like mentioned before… :(

This bug started for me a few days ago, latest version of iOS. I can see the observations in my observation tab but they’re not uploading to iNat. They were mostly organisms I observed when I had no reception but normally I can just open the app when I get home and they’ll upload then. This doesn’t seem to be the case anymore.

1 Like