Some notifications not loading fully on Android

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform: Android

App version number, if a mobile app issue (shown under Settings or About): 1.25.12 (527)

Screenshots of what you are seeing:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Android doesn’t always load the mention notications properly. Some show up with no preview description and no ability to click on it to open. Other mentions work properly.

Here’s the mention in the screenshot above, in case it helps:
https://www.inaturalist.org/observations/104467981#identification-077343b9-ee8d-44d3-9d34-55b9001c7fbd
After I opened it on the website, the app notification lost the green highlight, but looks otherwise the same (no photo or description.)

Step 1: open “activity” from menu of app

Step 2: swipe to “following” tab and be unable to click on one of the notications

Step 3: check the website and find the notification in question was a mention in an ID on an observation

1 Like

I moved your report to the bug reports category. Can you add in which version of the app you’re using? thanks!

1 Like

Was this a mention on an observation? I have seen this problem for comments (and mentions?) on flags which aren’t supported on mobile. The same is probably true for journal posts. From this update:
https://forum.inaturalist.org/t/inaturalist-updates-for-december-2021/28831

Yes it is a mention in an ID on an observation; my original post provides a link to the observation if you want to see it.

I could see how flags and journal posts would be too much for the app, but I’m feeling mentions on observations are the most basic type of mentions–indeed I have other mentions on my app notification list that worked just fine. The December update just says “Support for mentions” and doesn’t go into any more detail.

I’m facing the same issue. Android 6.0.1 iNat 1.25.12 (Portuguese)

Made a bug report: https://github.com/inaturalist/iNaturalistAndroid/issues/1169

1 Like