Taxa page map always centers off Peru coast

Platform (Android, iOS, Website):

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Chrome. Firefox seems to work.

URLs (aka web addresses) of any relevant observations or pages:
Every taxa page, but one example is:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Everytime I go to a taxa page in Chrome and then its Map tab, the map always centers just off the Peruvian coast, rather than going to a relevant location on Earth that contains the sightings for that taxa.
This used to work, but no longer does for some reason. I tried Firefox and it still works correctly.
I’ve tried clearing cookies from iNaturalist, but that did not fix the issue.
This started probably in the last two weeks.

You haven’t set a default location for your account have you?

1 Like

Maybe unknowingly? I’ll search for that. Didn’t know it was a thing. Thanks.

Would that be the same as the Default Search Place under my settings? That field is still blank.

If I had set a default place for my account, wouldn’t it be the default for any browser? Seems to only affect Chrome now.

Perhaps you have set the location to the Peruvian Coast on the “Place Filter” on the taxon page? It will be at the top right corner of the taxon page (it will be shown as “Filter by Place” if you haven’t set any location previously, or the last location you have changed here), as shown in the screenshot below

hope this helps :)


It should affect all browsers, and it looks like it’s not set if you examined your settings. Likely an issue with something else then.

Have you tried logging into iNat in an incognito window and seeing if the result persists? Maybe some of your cookies are messed up.


That taxon shows San Diego map for me (from Cape Town)


Yes, this is what I get for the map tab from the taxon page in Chrome:

which looks as I would expect.

If I set a place filter to Peru, I get this:

1 Like

Yes! Thank you. It had Ecuador selected, which apparently persisted all this time. I need to start paying more attention to that tool bar!

It’s odd that it saved that setting only in Chrome. I had cleared the cookies from iNaturalist, so if it was saved as a cookie it should have been fixed. If it was saved in the account, it should have affected all browsers. Strange. It was driving me nuts.