Taxon page: Middle-clicking doesn't open in a new tab for some links on taxon page (Firefox)

Links also open in the same tab when middle-clicking anywhere in the “Taxonomy”, “Trends”, and “Similar Species” tabs on taxon pages. Same for the taxon breadcrumbs just under the header. Ctrl-clicking, I’ve just discovered, does work.

1 Like

Hmm, I’m not able to replicate that one. For example, on this page:, ctrl-click and middle click open all these in new tabs for me:

  • taxonomy breadcrumbs in header
  • trends: view all or any of the taxa
  • taxonomy tab: taxonomy details, taxon changes, taxon schemes, hierarchy, manage names, add a name, edit name
  • similar species tab: any of the taxa

This was on Windows 10 / Chrome – I didn’t try Firefox.

Firefox on Windows 7 for me.

1 Like

I tried some of this on a Mac using Safari, Firefox, and Chrome. What I’m seeing (identical on all three browsers) is that command-click (normally opens in a new tab, equivalent to middle-click) just replaces the tab contents for the row of Map/About/Taxonomy/Status/Similar Species links. In all other links I tried, including the breadcrumbs at top and links inside the Taxonomy section (e.g.), a new tab opens as expected. Looking at the HTML behind these Map/About/Taxonomy/Status/Similar Species links, I see that they have an attribute data-toggle=“tab”, and it seems that a JavaScript library called “Bootstrap” is involved. It seems that this behavior is, if not exactly intentional, the expected behavior for these elements using this Boostrap library.

However, the breadcrumbs at the top of the page (e.g.) seem like normal links. They are behaving like normal links to me. @JeremyHussell, can you double-check that these breadcrumbs are not supporting regular middle-click behavior for you?

I can confirm most of the behaviour using Firefox 67.0.4 on Linux.

For the Taxonomy page, middle-clicking on items in the hierachy or the breadcrumb does not open them in a new tab - but ctrl+click does. The other links on the page seem to work as normal, though. For the Trends and Similar Species pages, it’s a similar story - middle-click does not work, but ctrl+click does.

It seems to be a bug related to Bootstrap, since it is required for opening those links (i.e. disabling the script means the problematic links no longer work at all, but all the other links still do). From what others are saying, the bug only seems to affect Firefox (and on all platforms).

I don’t think cmd+click on Mac is exactly equivalent to a middle-click (with the mouse) on other platforms. It’s more like ctrl+click, which is working as expected.

But the behaviour is different depending on which browser used - so it is clearly not always working as expected.

Agreed, there’s definitely some weirdness here. I suspect that the weirdness all lies inside the Bootstrap library, and thus might be difficult/impossible for iNaturalist to directly address. But maybe there is some way to work around the issues in iNaturalist, or perhaps there’s some alternative way to use the library that doesn’t have these issues.