Taxon page photo browser not displaying photos properly

I have this same problem with several taxa. Sometimes I find a hidden filter for term_id and if I remove everything from the URL from ? to the end, I can see the photos. Sometimes if I apply and remove filters, it then works but not always. It seems that when it fails for me, I eventually end up with this troublesome string for several taxa: “term_id=12&term_value_id=14”. Maybe that’s a clue or maybe just me.

I’m using Chrome on MacOS 10.15.7, Catalina.

I tried a test of several taxa using Safari and didn’t have any trouble, but I haven’t been using that browser much recently.


Had the same issue since three days ago in all taxa I browsed. i followed your guidance and now I do these three steps for every taxon:

  1. let’s say the original url path is:
    Here no photos are displayed.
  2. I click on the grid layout option that is not active, now the url path changes to:
    Still no photos are displayed.
  3. In the url path I delete this part: “&term_id=1”, and press the Enter key
    Now the photos are visible

removed “term_id” filter and I can see the photos again,

Hope this gets fixed soon

1 Like

OK, so the original bug here has been fixed - if you have set a filter which does not apply to the current taxon (eg Sex: Male for one taxon, and then load Kingdom Fungi, which has no Sex filter), you won’t be prevented from seeing photos. At least I haven’t found any cases where you see “No observations yet” even though there are observations that should load. If you do, please provide specific details.

There are a few kinks needed to be worked on, such as filters that should be “sticky” becoming unstuck, we’re looking into those.


Thanks! This seems to be working now. I tested by setting life stage Nymph on Pentatomomorpha, navigated to Fungi which briefly showed no observations but after a second or two, filled up the page with photos, then I navigated back to Pentatomomorpha and it still had life stage Nymph set.

1 Like

What I thought was an issue actually isn’t, so it should be working as intended now. I’m going to close this bug report.