Unable to create new taxon framework relationship when setting 'Fungi' as the taxon

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

Browser, if a website issue (Firefox, Chrome, etc): Opera

Go to https://www.inaturalist.org/taxon_framework_relationships/new, and fill out the following details:

When you click save to create the relationship, the internal taxon gets destroyed and nothing gets saved:

I tested the problem by adding a new plant species just now, and filling out the form, and everything worked perfectly and it got created.

I then tried to create the fungus framework again, but this time instead of selecting Fungi as the taxon in the top dropdown menu, I selected Tracheophyta, and it worked as well. So it seems like selecting Fungi from that menu is causing the problem

I’m puzzled why you want to create a TaxonFramework relationship with IndexFungorum? It is a nomenclator - the fungal equivalent of IPNI - and not a source of taxonomic opinion. There is a related database called SpeciesFungorum for taxonomic opinion, but it is not reliable or current enough to be considered as a general taxonomic source for iNat.
IF is a good source to cite for the name (when adding the name to the iNat database) but not in a TaxonFramework relationship.
Curator Guide · iNaturalist

My apologies, thanks Jerry. This is (from memory) the first fungus species I’ve added to iNat (I mostly add plants and inverts), will follow your advice for any I add in future.

The bug still stands though given it’s the dropdown option that is affected