Unable to delete a subscription

A couple of weeks ago, I tried to adjust my subscriptions by deleting a place (“Heracleum genus in Vermont”) and adding a taxon (“Heracleum genus”). That was only partially successful since now there is no subscription in my subscription list to edit. How do I remove the invisible subscription to taxon Heracleum?

Thanks in advance,


1 Like

@trscavo - as an iNat admin I can log in as you - this would probably be the easiest way for us to diagnose what’s happening, but I want to make sure it’s OK with you.

Yes, please.



OK, I see the issue. You can access all of your subscriptions by clicking on the gear icon next to Subscriptions:

Then click on Taxa, on the left-hand side:

You should then see a list of all taxa to which you’re subscribed, and you can edit those subscriptions.

1 Like

Thanks @tiwane, that seems to have done the trick.

If all subscriptions are not listed in the top-level interface, there should be some indication that there are more via a secondary interface. I had no idea that I could dive deeper into the interface and eventually do what I want.


1 Like

Thanks for hte feedback @trscavo, i’m glad it worked. Feel free to make a feature request about this if you like, so we can keep track of it.