"Undefined" pop-up when editing a project with a long species list

Platform: Website

Browser: Firefox

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/projects/rossiya-i-krym-dyrki/

Screenshots of what you are seeing:

Description of problem:

Step 1: I’ve made a project with a long list of my expected lifers. It includes 808 species. I’ve tried to make this list longer, but project failed to be saved (“Undefined” pop-up). So, I stopped at 808 species.

Step 2: I’ve tried to remove some (one, ten, hundred) species from the project, but faced the same “Undefined” pop-up. So, at the moment I can’t change any filters of the project.

this has problem has been discussed in previous threads. looks to me like the fundamental problem has never really been effectively addressed.

1 Like

Oh, yes! Thanks for noting this, @pisum.

@tiwane, I still have this bug which was considered to be fixed (https://forum.inaturalist.org/t/project-not-saving-error-message-undefined/40645/19?u=apseregin)

for what it’s worth, the immediate problem, based on the text of the Github issue, seems to be a timeout setting on the server that is too short. this means that if you were to try updating again during a period when the system is unlikely to have a heavy load, you might be able to accomplish your update.

alternatively, you could try to make your updates using the API directly, as described in some of the related threads i noted. as far as i can tell, the project definition screen processes updates by processing the entire project definition, not just the parts that actually changed. but if you use the API directly, you can make requests to change only the things that actually need to be changed, which will take less processing time and thus avoid the timeout problem.

as far as i can tell, the developers probably never envisioned that folks would want to add hundreds or thousands of taxa to their project definitions. so the only way to really address the fundamental problem is probably to (1) establish a hard limit for items that can be added to the definition, and (2) to process only the things that actually changed in the defintion when the project definition is updated. (simply extending a timeout setting probably isn’t going to cut it.)

1 Like

Platform (Android, iOS, Website): Website

Browser: Chrome

URLs (aka web addresses) of any relevant observations or pages:
https://www.inaturalist.org/projects/underrepresented-vascular-plants-of-bc

Screenshots of what you are seeing:

Description of problem: broad strokes: I am unable to save changes to a project that I created and admin

Step 1: Open project page for “Underrepresented Vascular Plants of British Columbia”

Step 2: Click “Edit Project” button

Step 3: Opens “Project Details” page as normal

Step 4: Click “x” button on “Rumex transitorius” in the inclusion filters section

Step 5: “Rumex transitorius” disappears from list of included species as normal

Step 6: Click “Done” button

Step 7: A pop up window that reads “www.inaturalist.org says undefined” appears (see screenshot) with an “OK” button

Step 8: Click ok button (pop up disappears)

Step 9: Check project page and changes have not been applied

1 Like

I moved your post to an existing thread for this issue.

Hi, the same problem here when trying to edit the taxons list in the project “EXOCAT”.
Would like to see the last answers on this issue, where is the last thread? Is there any solution so we can continue adding taxons to the list? Thank you so much.

Laura.

Welcome to the forum!

This is the thread that the post above was moved to, so if you’ve read this thread, you are seeing all the feedback so far.