Project not saving (error message undefined)

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): I edit my project (mainly adding and clearing out taxa) and when I go to save my edits to my project, an error: undefined message pops up.

2 Likes

can you please share a screenshot (or screenshots) of how all of the project’s settings appear just before you try to save them?

Yes.




Looks like this is the project, correct? https://www.inaturalist.org/projects/new-york-state-endangered-vulnerable-and-threatened-species (please include URLs in bug reports)

I suspect the project might have too many requirements in it and something times out when it’s being saved. There are a lot of taxa in there.

Just for reference, I have also had this happen to me a few times but I assumed it was my phone (also iOS) acting up. If I can replicate the issue I will take screenshots to add, if that’s useful.

Also having the same issue. Previously having numerous taxa on a project did not result in this error. I’d say since last month has this been a problem. I think now you can only list 400 taxa on a project without an error message, maybe less.

1 Like

I’m having this issue too - I have a project where I add taxa I want to focus on finding, and then remove them once I have that species. It has around 900 species, and previously worked just fine, but today I went to remove about 60 of them and then it gave me the “undefined” message and wouldn’t save.

1 Like

Were the taxa eventually removed?

Nope.
I played around with it a bit and progressively removed more taxa while intermittently attempting to save - I finally got down to zero and it still gave the “undefined” error. Then I removed all the project requirements, same thing.

1 Like

Any movement on this?

Also getting this error, when editing species lists on projects.

1 Like

It wont solve this bug, but might this be an opportune moment to request that instead of entering large numbers of species one by one, we can do it via a list?
I suspect that a feature request for this is already posted, but perhaps it is time to review it?

The list option exists for Traditional Projects, but was abandoned for collection projects.
But editing projects with 100s (or 1000) of species is not efficient at all. If they could be put into checklists and then linked in the project, that would be far faster and more rational. And editing checklists is relatively straightforward.
e.g.
https://www.inaturalist.org/projects/trees-of-southern-africa-list - 1500 species.
rather link to:
https://www.inaturalist.org/check_lists/3196131-Trees-of-southern-Africa

1 Like

https://forum.inaturalist.org/t/filter-collection-project-using-taxon-list/6470

I ended up splitting my project into several smaller projects to get around this glitch.

Any updates on the resolution of this glitch? Surprised it hasn’t been fixed given the large number of projects on iNat with large taxon lists.

@tiwane Do you know if there are plans to address this issue? Or are project requirements now permanently capped at <400 taxa now? This apparent glitch has completely paralyzed the hundreds of iNat projects that use large taxon lists that can no longer be edited whatsoever, even the description. Would like to know if it’s going to be solved before following the steps of @dominid and taking the time to split up projects and re-enter hundreds of taxa again. Thank you again for taking the time to review the various bug reports on here.

are you really adding hundreds of taxa one by one to the project criteria? it should be possible to these in bulk via the API. back in the day, i asked @maxo how he was making such changes, and he said that he was doing it programmatically. maybe if you ask nicely, he might be willing to share scripts or tools to do this?

although i can understand why the system might refuse to add or remove hundreds of criteria in on transaction, based on my previous experimentation with the API to update projects (https://forum.inaturalist.org/t/edit-project-breaks-entirely-for-project-with-undefined-user/30070/13), it seems like if even a minor change is not being processed, it would be because the screen is sending the API the entire project definition rather than just the changes. seems super inefficient from the perspective of making updates to projects, although i suppose the screen would be easier to code if you didn’t have to keep track of the changes that occurred.

but i guess until the problem is resolved, if you need help making minor updates to a project, and are willing to try using the API to make such changes, i can describe some steps to make the necessary changes.

1 Like

You can use the iNaturalist API like this to add any number of taxa in batches, say 500 at a time.

var count = 1
taxons.forEach((iNatTaxon) => {
  setk(`project[project_observation_rules_attributes][${count}][operator]`, "in_taxon?")
  setk(`project[project_observation_rules_attributes][${count}][operand_type]`, "Taxon")
  setk(`project[project_observation_rules_attributes][${count}][operand_id]`, `${iNatTaxon}`)
})
var url = 'https://api.inaturalist.org/v1/projects/' + projectid
request.put({url, headers: {'Authorization': auth}, formData}, callback)

If you do a second batch, you have to start your count from where you left off. Warning that doing this method makes the iNaturalist UI crash (same as OP is getting) when trying to update any other details

2 Likes

Apologies for not making an issue about this earlier, but here it is now: https://github.com/inaturalist/inaturalist/issues/3820

Does anyone have examples of projects where this happens consistently, so we can take a look? That would help us when investigating.

This should be fixed.

1 Like

This topic was automatically closed after 18 hours. New replies are no longer allowed.