Uploading edited Google Photos images from desktop results in uneditable NaN values for dates

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Go to Google Photos website from PC/laptop, edit an image.

Step 2: Download edited image to desktop

Step 3: Upload to iNat on the website. In the past, editing in Google Photos would result in a missing date, which I’d manually add. Now, it results in an “invalid date” and I am unable to change the date to a valid one, preventing uploading the observation.

Just adding another comment - even if Google Photos is breaking the date format, iNat shouldn’t also break. The expected behavior for me is that I can manually set the date. If needed, I can record a video showing the workflow start-to-finish.

Also, as a test, I tried downloading the editing image on my Android phone, and then uploading them to iNat using the app, and it worked just fine, and was even able to import the date.

you probably should make one of these edited photos publicly available and send the link to iNat staff so that they can examine and test using that photo.

i can’t reproduce your issue on my machine. the extracted dates on uploads using GP-edited photos look fine. so i assume that there’s something about the metadata saved in your file or something in your workflow that is needed to trigger the problem.

FWIW, I just tried to recreate the issue with some fresh photos, and as you mention, the problem is no longer occurring. However, if I re-download the problem files, the problem persists.

I inspected the EXIF data on the problem photos and the fresh photos that work, and the problem photos are missing much of their EXIF data.

Here’s a link an example problem photo:

My theory at the moment is that Google had something amiss in their EXIF handling yesterday, and corrected it. However, I still expect iNat to have appropriate error handling to avoid surfacing a NaN to users.

I agree. I find it hard to imagine a scenario in which it would be intended behavior for the user to be unable to edit the date of their photo (though that isn’t to say there isn’t one).

i downloaded your photo and tried to upload, and i got the same error you did.

as best as i can figure, the value in the “Date Taken” metadata field visually appears to be blank, but there must be some sort of odd character – like a space – in there that’s not obvious. the upload module must be picking up this value, and since it’s not a date (or some sort of number), then the upload screen doesn’t know how to handle it.

i suppose the screen should be able to handle unexpected data in these field, but since i don’t recall ever seeing this kind of thing before reported, i suspect it would be a very unusual situation in which any program allowed you to write bad data into that field. (so does such an unusual situation even need to be handled? i’m not sure.)

there are many different ways to work around the problem though. just a few options:

  • delete the “invalid date” text, and replace it by typing in a date in a format that iNat accepts (ex. “2023/12/11 6:50PM”)
  • add a blank observation, set the date using the date picker, and then drag your problem observation onto the new observation. that should merge the 2 observations together in such a way that you end up with a single observation with a good picture and a good date.
  • before you upload, modify the “Date Taken” metadata field value in the image file. (in Windows, i found the file using File Explorer, opened the Properties popup for the file, and changed the “Date Taken” value in the Details tab.
  • before you upload, remove all metadata values from the image file (except for those that are required). (in Windows, i found the file using File Explorer, opened the Properties popup for the file, and selected the option to remove all unnecessary values.)

Made an issue here https://github.com/inaturalist/inaturalist/issues/3960

@naturesarchive can you explain your workflow in a bit more detail? Which edits are you making? I couldn’t replicate when I uploaded an image from my dedicated camera to Google Photos, edited both the crop and clicked the “enhance” button, then downloaded the result to my computer.

I’m not able to reproduced the issue anymore either (see post 4, Dec 17, 4:15 PM). However, I did link an example problem photo, which continues to trip up iNat. I think there is an issue in the data validation or error handling, which is reproduceable using the example photo.

For what it’s worth, the original photo was cropped inside of Google Photos, then downloaded to my desktop, then uploaded to iNat. That’s it. Several subsequent attempts have not resulted in it repeating.

Hope that helps.

1 Like

Thanks, yes, I was able to workaround the issue, but was more concerned about the error handling/data validation issue that it demonstrated.


Here is a fresh instance from today. I edited two photos in Google Photos website - the one that I only cropped has the problem. The one that I cropped and adjusted exposure didn’t have the problem. I don’t have time at the moment to investigate further, but here’s the problem photo link in case a second example is needed:


Web uploader, chrome, ubuntu.

I recently reset my camera and forget to set the date and time, leading to a bunch of photos which have no date information. Trying to upload these is impossible as the uploader says “invalid date” but at the same time does not allow you to change it. I tried typing in the date and that also did not work.

I found a work-around by adding a photo with a valid date then selecting all and changing the date and deleting that other photo. But there’s certainly still a bug here.

Possibly same as: https://forum.inaturalist.org/t/uploading-edited-google-photos-images-from-desktop-results-in-uneditable-nan-values-for-dates/47563/1

Appears the same indeed. @forum_moderators can this be merged with that topic.

1 Like



This should be fixed. Your photo doesn’t result in the NaN issue any longer, @naturesarchive.

1 Like

This topic was automatically closed after 18 hours. New replies are no longer allowed.