Web uploader saving only first 1-2 observations in a batch

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

Browser, if a website issue (Firefox, Chrome, etc) : Firefox 88.0.1

URLs (aka web addresses) of any relevant observations or pages:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Not sure you will be able to replicate this, but it started happening consistently for me about 3 days ago.

Step 1: Initially created the three observations linked above as a single batch in the web uploader (in that same order in the uploader), then clicked “Submit 3 Observations.” Response said “Saving 3 Obsservations,” then “Going to your observations,” with no errors or other messages.

Step 2: Observations page (https://www.inaturalist.org/observations/jdmore) initially showed none of the new observations.

Step 3: Refreshing observations page after a few seconds, only the first observation listed above became visible. Repeated refreshes over the next several minutes, but the remaining 2 observations never appeared.

Step 4: Re-created and re-saved the missing two observations in the web uploader one at a time, with no problems.

Step 5: Same thing happened with the preceding 4 observations uploaded three days before, on May 21 (see on https://www.inaturalist.org/observations/jdmore). Initially submitted as a batch of 4, but only the first 2 saved (see the timestamps). Had to re-create and re-upload the remaining 2 individually to get them to save.

Previously I’ve been able to save a dozen or more observations in a batch with no problem, with similarly lengthy descriptions and tag sets and numbers of photographs of same sizes.

Wasn’t sure if this was the same problem as in
so I made this a new thread for now instead of re-opening the old one.

i tried reproducing this, and i couldn’t. i even tried throttling my connection to down 50 Kbps / up 20 Kbps / latency 500ms, and that didn’t seem to cause any problems either. if you are able to consistently reproduce this, what i would do next time you’re going to upload is:

  1. before you go to the iNaturalist Upload page, in Firefox, open up the Web Developer Tools
  2. go to the Network section
  3. in the Settings menu (the gear button), check Persist
  4. now go to the iNaturalist Upload page, and complete your upload
  5. if there are issues with the load, then in the settings menu in Web Developer Tools > Network, select Save all as HAR. save the file somewhere and e-mail it to staff. (don’t share the file with anyone you don’t trust, since it can contain credentials and other sensitive info that you don’t want to share with randos.)

Thanks, I’ll try that next time.

1 Like

I use Firefox as well and uploaded abunch of observations over the past few days but didn’t encounter any issues. Looks like these have a bunch of tags, I’m wondering if something there might be causing a problem? Can you send those photos to help@inaturalist.org? What if you remove all the tags before adding them to the uploader?

1 Like

Most of my past observations have been uploaded with similar numbers of tags, with no issues except when I exceed the 750-byte limit, and then I’ve been able to recover by hitting the back button and removing a few tags.

I’ll try @pisum’s suggestion and also send you the photos from the previous attempt. There are 7 originals at 6-8 MB each (which the uploader has also handled fine in the past) - how much can your email handle at once?

1 Like

eh, pretty much as much as you want, but I think 3 photos should be fine.

1 Like

Hey Jim, forgot to say that unfortunately the har file didn’t have anything helpful in it, alas. How’s your internet connection?

Thanks for following up Tony. Internet connection is broadband and generally fine. I did discover that the problem seemed to resolve after I closed and re-opened Firefox, which I hadn’t done for a while. So maybe a cache space issue…? I don’t know. But I’ll go ahead and close this, as the issue seemed to be at my end, whatever it was.

1 Like