500/"Ate It" Error on Flickr Import for specific images ~5MB, ~2600x3300 pixels

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About): NA

Browser, if a website issue (Firefox, Chrome, etc) :
Chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Login to iNaturalist, and click the Upload button. iNat opens the Add Observation page.

Step 2: On the iNat Add Observations page, click More Import Options, then select From Flickr, etc. from the drop-down. iNat opens the Import Observations page.

Step 3: On the iNat Import Observations page, iNat should default to *Source: Flickr. If not, select it. iNat should populate the first page of your Flickr photos, ~90 images.

Note: This requires a Flickr account.

Step 4: Select the photo to import. Click Import Photos. iNat takes you to the Add a Batch of Observations page.

Note: This is the exact same Image A used in the Observation, but loaded from my local drive.

Step 5: The iNat Add a Batch of Observations page initially looks fine.

But if you expand the Photos panel, iNat doesn’t show the thumbnail for the photo.

Normally at this point, I would select Image B, as well.

Step 6: On the iNat Add a Batch of Observations page, click the *Save All button. iNat returns the “Fail Whale” page, HTTP Status Code: 500 Internal Server Error. No other information is provided.

Additional Details

Payload from submitting the Observation:

utf8: ✓
authenticity_token: cCGXEy1j1HdCSn4NP6J+7oO0mAWPSuuv3XXBgrqs3AK6jYaNm7fV1bU8BS0Xk/ili18DiD3SURHRc601UUCXWA==
observations[0][species_guess]: Banded Graphisurus
observations[0][taxon_id]: 322989
observations[0][observed_on_string]: 2024-05-29 10:22:42
observations[0][place_guess]: Beverly Square East, New York, United States
observations[0][latitude]: 40.642636
observations[0][longitude]: -73.968373
observations[0][positional_accuracy]: 
observations[0][map_scale]: 16
observations[0][location_is_exact]: false
observations[0][positioning_device]: 
observations[0][description]: Banded Graphisurus (Graphisurus fasciatus) in my front yard, May 2024
observations[0][tag_list]: 2024-05-29, 2024-05, May, May 2024, 2024, Brooklyn, Kings County, NYC, New York City, NY, New York, My Garden, Flatbush, Banded Graphisurus (Graphisurus fasciatus)
observations[0][geoprivacy]: 
observations[0][force_quality_metrics]: true
observation_field: 
photoSelectorSearchField: 2024-05-29
flickr_photos[0][]: 53757926794
editing_sounds: true
local_sounds[0][]: (binary)
2 Likes

And it’s only this photo? Do any of the other Flickr photos cause this error? I don’t think file size has to do with any of this, I’m able to import a huge photo like this one from Flickr.

Yes, it happens with either of these two specific photos, Images A or B. I tried it multiple times before trying to upload it manually.

The same error occurs if I try to add Image B from Flickr to the Observation with the manually-uploaded Image A. Or if I try to add A from Flickr.

I have another Observation from the same day with an even larger image imported from Flickr with no issues. Whatever it is, it can’t be just their sizes.

There are a few more problem isolation steps I can think of, but they all involve re-uploading - in case there’s some difference on the Flickr side - or re-processing - in case there’s something about their actual bits! - the images to see if they still trigger the issue in iNaturalist.

I suspect it’s something weird on the Flickr end, but I don’t know what it’d be. Can you email the photos to help@inaturalist.org? I can try to replicate.

Sent!

1 Like

It worked for me (observation since deleted).

Looks like your Flickr page for the image has some tags in it, whereas mine doens’t. Maybe that’s causing an issue. Have you tried removing the tags one by one and seeing if that helps?

I was suspecting something related to tags, also. Confirmed, but it’s not what I expected.

Hypothesis: iNat chokes on tags added in Flickr when the original photo had no tags when uploaded.

My usual image processing workflow is:

  1. Offload from camera to local drive.
  2. Import into Lightroom.
  3. Process in Lightroom:
  • Cull, e.g.: lens cap on, out of focus, blurry, etc.
  • Add Titles and Descriptions
  • Verify/Correct locations
  • Tag images
  1. Select images for Observations, and crop, adjust light, color, etc.
  2. Export to local folder.
  3. Upload from local drive to Flickr.
  4. Import to iNaturalist from Flickr for Observations.

After Step 5, the Tags can be seen on the images in the local drive. After 6, the images are already tagged in Flickr, and get imported into iNat in Step 7.

I looked again at the export folder containing the original images. I noticed that these two images did not have Tags on my local drive. I hadn’t tagged them yet in LR (Step 3) before I exported them. So they also didn’t have tags when first uploaded to Flickr. I added the tags to them in Flickr after upload.

I had later tagged the images in LR. So I re-exported Image B; it has tags in the local folder. I re-uploaded it to Flickr; let’s call it Image B.2.

I was able to import Image B.2 into iNaturalist as an Observation with no issues!

Problem Isolation Notes:

  • Image B.2 has the same tags in Flickr as Image B.1 in Flickr which fails with the 500 error.
  • In Flickr, the tag order is different. I don’t know why that would be significant, but I’ve seen stranger.
  • In Flickr, Image B.1’s EXIF has no Keywords: field. This makes sense, since the image itself wasn’t tagged when imported.
  • In Flickr, Image B.2’s EXIF has the Keywords: field, though it appears truncated when viewed in Flickr. When dowloaded from Flickr, it has all its tags, from the image EXIF.

I’ve attached the downloaded Image B.2 so it can be compared with B.1. I’m leaving the Observation up for now until we can isolate this; I flagged it as a duplicate of the original.