Import from Flickr failing w/500 Internal Error all day

Note: I searched for current (since 8/1) Bug Reports mentioning “Flickr” and could find none. This has only been failing for me today. It was working fine as recently as Monday.

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About): NA

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages: Upload > Import > from Flickr

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: Fail Whale Shark (500 Internal Error) page

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): Attempting to import any photo from Flickr to upload a new observation fails every - or nearly every - time with 500 Internal Error.

Step 1: Upload > More Import Options

Step 2: Select “From Flickr, etc.” from drop-down and select (check) a photo.

Step 3: Scroll down the selection page and click the Import Photos button.

Step 4: Click the Save All button and get the Fail Whale Shark (500 Internal Error) page.

1 Like

This started yesterday and we’re investigating it, I’m sorry it’s affecting you. We believe it’s something on Flickr’s end.

What’s weird is that some photos can be imported, at least in my testing. This photo of mine is imported consistently, whereas this one consistently results in a whale shark error.


Github issue here:


I haven’t been able to import any photos at all from Flickr since the 8/8. All looks good until I try the final upload step, then I end up with the Whale Shark. (Chrome on Mac)


This has also been reported on the Flickr Help Forum. Maybe if more of us enter our experience with this problem there, it will start to get some attention from Flickr.

I don’t know where in Flickr we can enter a more formal “bug report”.

Thank you! Tracking there.

As a former professional developer, I appreciate being able to see the problem isolation effort and low-level API responses.


I opened a ticket at

Subject : Flickr API fails with 429 Too Many Requests on iNaturalist request

This problem is reported and described in the Flickr Help Forum.

iNaturalist is tracking it on their end with a GitHub Issue. That has technical details of how their API calls are being rejected by Flickr, and their problem isolation steps that show the problem is with the Flickr REST API call responses. That information should be helpful to you to identify and correct the problem on your end.

I got an immediate, automated email response:

Thanks for reaching out to Flickr Support! We’ve received your message and due to some Flickr Heroes being out of office, there may be delays in our response to your inquiry.

If you’re a Flickr Pro member and the specified email address is linked to your Pro account, your message is in our VIP queue. For Pro product support-related issues (account management, troubleshooting, bugs, etc.) you should expect to receive a response within 8 hours.

Since I’m a Flickr Pro member, as are the others reporting this issue to Flickr, I hope we get a resolution from them sooner rather than later.


I tried a different route to see if there any difference. As expected, same failure. I assume the backend Flickr API calls are the same, or nearly so, regardless of where in the UI the request originates.

  1. Uploaded an Observation with 3 photos from my hard drive I had already uploaded to Flickr.
  2. Edited the Observation.
  3. Deselected 2 of the 3 photos, and selected their replacements from Flickr.
  4. Click Save Observation.
  5. Fail Whale Shark

I just tried again importing 2 photos from Flickr to create a single new Observation. It failed. I clicked the browser back button to return to the Upload page (which loses any edits I made, such as adding other photos). 4 attempts failed with Fail Whale Shark. The 5th attempt unexpectedly succeeded. However, it only took the single image.

I edited the Observation to add the second image from Flickr. 1st Attempt failed. Went back in the browser, refreshed the Edit Observation page, re-selected the second photo, and tried again. The 2nd attempt succeeded.

This is consistent with the HTTP/2 200 - x-cache: Miss/Hit ... responses described in the GitHub issue.



We are really sorry for the situation.
We also contacted Flickr support yesterday, but didn’t get a reply yet.
We are pretty sure they are “simply” banning our IP range (20.x.x.x).

About your scenario, the fact is we have currently 7 servers handling the observation creation.
6 are in 20.x.x.x IP range and 1 is in 40.x.x.x.
This is why you have a 1 in 7 chance that your Flickr import will succeed.

Sorry again.


I have the same issue - not been able to upload anything via flickr since 8th of August. About 10 attempts made. Can anybody advise if this is likely to be a long term issue or permanent. Will submit complaint to flickr today. Thanks

Hi - just to say I have also contacted Flickr support. The auto reply says I will get a response in 8 hours, we’ll see…

I’ve had a reply from Flickr Help Support - it’s the other guy’s fault!

“Sorry for the trouble with this. As it sounds like you are able to upload to your account normally through Flickr, this sounds like an issue that will need to be addressed by iNaturalist. They may need to update their application to account for any changes to the API.”

I have managed to upload some Flickr images to iNat, but they can take many attempts e.g. one took 31 before it was saved!

1 Like

I also got a reply from Flickr support.

"I understand you are having trouble with uploading your Flickr photos using the integration iNaturalist has with us on their platform.

As this is not an error on Flickr’s end, we are limited in the support we can provide. At this time, we will need iNaturalist to directly reach out to us so we can best assist them to get things working again.

I do apologize for any inconvenience. Please let me know if there is anything else I can assist with."

Is anyone knows what’s wrong?

1 Like

This was the reply I got today, 12/08/23:
My name is Carol and I am part of the Flickr Support Team. I’m glad I have an opportunity to assist you today.

I understand that uploading to the iNaturalist site directly from your Flickr account recently stopped working as expected. I see that this feature is important to you, and I can empathize with the frustration it is causing.

There is an active thread about this issue in the Help Forum that might offer some useful information:

At this time, we don’t provide any official support for API questions. If you’re having issues using the API, and need assistance with how to utilize it on your site or project, we recommend reaching out with the Flickr API group for the best assistance.

You can join the group here:

Some other resources that might help

Please let me know if you need further assistance. I am genuinely happy to help.

Kind Regards,


We still haven’t received a response, but I am not a premium user…

Would it be possible, for those who received a response, to reply to them to contact me for additional details (

It’s not related to the API in my opinion. Our issue is with a different endpoint, the static endpoint, used to get the photo file.

Thank you.



I noticed that uploads were again working this morning. Flickr Support confirmed this in an email I received this afternoon:

We’ve worked with our engineers to get to the source of the problem on our side and the uploads should now be working again.

We do recommend adding an obvious User Agent to your upload requests through iNaturalist.

Please let us know if you continue to experience this, though, and we will circle back with our engineers.


Sweet, I got that message as well, and I passed their advice on to our devs. Flickr import is working for me again.

1 Like

I also received the same message and my first upload went through without a problem.


1 Like

This topic was automatically closed after 18 hours. New replies are no longer allowed.