Adding obs to project: Didn't pass rule: must have a photo - but has photo

Has anyone seen the bug where an observation did not initially upload with a photo due to an app glitch. Then user gets to properly adding the photo (Yay!), but now we can’t add the observation to a project (that requires evidence) with the error message “Didn’t pass rule: must have a photo”?

It has a photo now, so you would think that would update and no longer restrict us from adding.

The observation in question is https://www.inaturalist.org/observations/30648712
and adding it to the Ohio Dragonfly Survey Project.

Is there anything I can do on my end if this happens again?

Thanks for any help,

MaLisa

Happens when I tried to add it too… but I have not struck this happening before.

I think I recall having something similar happen a while ago. I had to delete and reupload it multiple times to get it to work.

If the problem still persists, try faving and unfaving the observation (and then re-fave if so inclined!). According to staff, this forces an observation to be reindexed throughout the system, and might just fix this particular issue too. Wait about 5 minutes, then try adding to the project again.

As things are added and edited in iNaturalist, a lot of background data re-indexing takes place all the time to support all the query functions on iNaturalist, and most of it is queued and can take several hours to complete after a change. This is a way to make it happen faster for a single observation.

1 Like

same bug as https://forum.inaturalist.org/t/obs-with-photo-failing-to-pass-project-rule-must-have-photo/3998

1 Like

Well, I tried favoriting and unfavoriting several times, but still no luck. It isn’t a super rare species, but I hope this doesn’t happen with something rare.