After editing and saving of place boundaries, going back to the edit mode shows the old boundaries

Platform: Website

Browser, if a website issue: Firefox 86.0

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing:
even after editing, old place boundaries are displayed (Firefox)

this is how the place should look like (Safari) [only the western part has been changed]

Description of problem:
After editing place boundaries, the new area is correctly displayed on the ‘places’ website as well as in explorer view. However, when going back to continue editing, I can only work with the old version. Switching browsers solves the problem, so I guess it is some issue with the cache? Logging out and in again does not provide a solution.

Yes, it is definitely the cache. If you zoom out or in, you will see the new boundaries … In fact it is really strange to see it alternate between both versions of it as you zoom in and out again across different zoom levels… This was raised a while back as a bug, not sure if they could find what causes it.

1 Like

Unfortunately, it is not a single zoom level - it is behaving as if the new version would not exist at all.
I can even start to edit the ‘old’ boundary markers:

I don’t know what would happen if I’d save those changes again, if this would overwrite my previous editing. (I will not try it out on this place, it was quite an effort to create)

How long has it been like this and what place is it? Complex kmls may take a while to get updated. Please don’t try to edit the place again yet.


It wasn’t a kml upload, I made the complete boundary myself.
Right now about 12 hrs have passed after saving.
And, as mentioned, switching the browser immediately gave me the correct new version (also editable normally), so it’s there on the platform - just my browser wants to work with the old version…

1 Like

It takes hours to update on Chrome, maybe Firefox needs even more time?

Please link the location so that we can look ourselves. I believe it is probably just an issue with your browser.

It’s here:

Still not updated in Firefox for me

try clearing the firefox cache? may or may not be something you want to do with respect other stuff you do on your computer, and also could stop developers being able to look into the problem…

before you go and just clear the Firefox cache, try this:

  1. open up firefox. open up the browser’s network monitor (web developer > network). pick just XHR (orange circle in the screenshot in the next point).
  2. go to, and look for a request on a file named 164294. note in my screenahot below, the status of the request for that file is 304. what status code do you see?
  3. now, click on disable cache (green circle in the screenshot above), and refresh the page. now what is the status code, and what does the place look like on the map?
  4. repeat the same process on the place edit page.

(it looks to me like FIrefox is being really aggressive about not re-requesting that file (which contains the place boundaries, i think. i don’t know why Firefox seems to do this and other browsers don’t.)


From the perspective of caching the edit view of the map, I think I was having that same issue with chrome, where you make the change and the default zoom level shows the old boundary, but zooming to other levels shows the modified boundary… maybe it’s related to this, maybe not, but it was definitely in Chrome that it was happening for me. If your suggestions don’t shed more light on this instance of the problem, I will have a go at some test places to see if I can figure out more on what happens for me.

yeah… strangely, different places in the site deliver the place boundaries slightly differently.

in the place page, the place boundaries on the map are delivered as tiled images, which could result in the different place boundaries at different zoom levels. in the explore page, i think the place boundaries are actually drawn based on coordinates in a json file, which should mean that the boundaries are drawn the same throughout different zoom levels. there’s something similar happening on the place edit page, where the place boundaries are delivered as coordinates, although in a slightly different way as the explore page. so again, on that page, the boundaries should not vary by zoom level.

i didn’t really dig into everything because i didn’t want to make a bunch of unnecessary place changes, but it looked to me like Firefox was being particularly aggressive (vs other browsers) about using the cache for coordinates, not necessarily images. i think the delivery of new images is controlled by a slightly different mechanism. so it should resolve itself more or less at the same speed across browsers.

1 Like

Thanks a bunch, @pisum!
Clearing the cache worked - here are the screenshots from the observation page, and the place edit page, respectively:

The question is, can anything be done on iNat’s developers end to prevent this from happening in the future?

hmmm… the second screenshot is not what i was expecting. i was expecting a status code on the first request, but there’s not one. it looks like the browser decided to use the cache, and it seems to have gotten a cached version of the coordinates from the server. but i don’t know why it decided to go with cache.

did you end up making any additional changes to your place? if so, did you notice the page still displaying old boundaries after the additional changes?

if not, i think the best thing might be to just say there was a temporary gremlin somewhere and move on…
if so, then i guess i’d have to try to replicate the problem myself before i personally can make additional suggestions. (i was hoping not to create/modify places unnecessarily.)

short of additional research, i suppose you could just clear cache or use SHIFT+refresh to force a hard reload of a page whenever you encounter the problem. (i’m assuming that you don’t modify places a whole lot. so you shouldn’t encounter this kind of situation a lot.)

I didn’t do further editing, but I might play around a bit when creating a new place.
It was not a one-time issue, I remember there was at least one more incidence, but quite a while back and I don’t remember the exact case.

Oh no no no! What happened?
I just checked, and now the place is reverted to its old status, irrespective of the browser! How can that happen? I had the new place saved in the above discussion, where everything seemed to be ok, so how can it revert afterwards? :sleepy:

Can you share a URL of where you’re looking, and perhaps a screenshot of what you see? The geometry I see at looks like the second screenshot you posted in your first post, which I believe you said is the updated (preferred) version (with an indent on the northern edge)

Maybe I posted too soon, in the moment of shock.
The ‘indent version’ was the intermediate step, i.e. half the editing was done, and I continued to work on the rest. But I can not promise that the final version was successfully saved - although I usually check the final result. However, I don’t think this issue can be solved now and I edited the map again to finalize it on a very rough degree

1 Like