All Projects showing an empty page

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Every time I click on a project I get this empty page, it doesn’t seem to matter what project, they all act the same

Step 1:

Step 2:

Step 3:

Also every species page is blank.
(I noticed on observation pages time of commens and ids are given in English, I remember it being translated or am I wrong?)

In Firefox it is empty, when I test in Edge it is working.

I just tried Edge and it still has the same problem for me

This was caused by a bug in a deploy this morning. A fix was just deployed. Could you try again?


working for me (firefox)

1 Like

Works now, thanks