Android app not reading picture location data

It’s not the same because it’s from the most recent update, it was perfectly working before 26 August 2023, including in December 2022

as i understand it, the issue manifests itself as a result of a change in Android itself, not in the iNat Android app. so you probably got an Android system update on 26 Aug, and that’s what caused the iNat app to start not working for you. as far as i know, the iNat app has not yet been updated to handle whatever the issue is, but you can work around the problem using the suggestions in your thread here and in the other thread.

1 Like

As far as I know, most of them are regular iNat users, but the difficulty with testing for these kinds of bugs is that most of the time they are specific to a particular model of phone, say, or only affect files that have been edited with a particular app, or only occur under a very specific set of conditions such as on phones with a particular default language, or whatever. As such, the bugs that make it through to the final version are almost always ones that only affect a small proportion of users, and so are not easy to stumble across just by a few people doing random checks.


Merged as this seems to be the same issue due to change in Android photo picker.

I do not think the merge is in order, something definitely happened! The picker is not unusable, but it works perfectly in PlantNET on th esame phone!!!

I opened a new report for that

No, it isn’t, other apps, like PlantNET, on my phone still get a better photo picker. Maybe they will also use the bad one when I update them, but I do not have automatic updates enabled as often that leads to problems like this.

I’m not sure what I can add to what I’ve already said. This is due to the Android photo picker being changed. We and others (including someone from PlantNet, a few weeks ago) asked Google to have the picker include GPS data, but they’ve said they won’t do it. I don’t know what other apps use, maybe they use a built-in picker they’ve made themselves, which is something we will likely have to do in the long term, but that takes time to make/change. We’re working on a solution but it’s not ready yet. In the meantime, there are two workarounds to address it:

  • go to your phone’s gallery and share photos to iNaturalist from there

  • click on the three dots in the new photo picker (right-hand side) and choose “Browse”. That seems to fix things.


I recently wondered why my observations were all in the Gulf of Guinea and required manual correction, now I know why (it seems to be a strange new “feature” in Android which requires separate permissions to read Exif data from pics where the permission to read the image itself is already present). The workaround works.

Inat 1.29.5 (579)
A53 5G (SM-A536B/DS)
Android 13, last update 2023-08-03

A new Android update was just offered (2023-09-01), I installed it.
It got worse, now the workaround also ignores the coordinates from the image.

With Plantnet, the builtin picker is also broken but the workaround still works (after the system update, didn’t try before).
Compare and

Interestingly, Plantnet actually complained about this issue (most recent comment on it):
So this is an issue that extends across similar apps.

2 posts were merged into an existing topic: The new Andoid app version now uses a very restricted photo picker

This is so frustrating… I just went and read the issue over on Google and it’s bizarre how they’re not recognizing that many, many people have very legitimate use cases for pulling this data!

@tiwane and others, just wanted to say thanks for looking into this, and for posting the workaround (works for me for now, on Google Pixel 6). Hoping for your sake that Google is able to get this resolved, or that they decide to stop being obstructionist about it. Let us know if there’s anything we, the iNat users, can do to help convince them.

I actually found out that the “share” workaround results into a faster workflow, because one does not have to scroll through the large collection to find the location where one was a minute ago all the time. I hope it will remain functional but with Google one never knows, they do what they can to be the only ones to have the consumer data that they can sell.

Having the same issue but it only started recently.

Correction (or update): the workaround seems to work. I don’t know whether I did a mistake last week (probably) or something changed.

We’ve started rolling out a release of 1.29.11 (585) to all Android users, and that should fix this issue. It’s working on both my Pixel 3A and Pixel 7. It should be available to everyone in the next few days.


I’m on release 1.29.11 (585) with a Pixel 6. My observations don’t get a location when using the new picker. Clicking “Browse” in the new picker and selecting photos using the old picker does bring the location over.

So I have a workaround but the default workflow is not working properly.

Exact same experience on my Pixel 7. The workaround is only a minor annoyance for me but probably challenging for casual users. So annoying that Google won’t budge on this.

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android):

App version number version 13

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem This appears to be the same problem that people were discussing in Dec 2022 (I think) but I did not have this issue until now so I wonder if it IS still the same bug. I noticed the issue after my phone force updated overnight. The workaround that someone suggested last December where you by-pass this new photo picker did work but I would prefer not to have to go through a bunch of extra steps for every single observation I post with the app. Is there anything in the works to fix this bug?

Step 1:

Step 2:

Step 3:

Moved your report to this current thread which seems to be about the same issue.