Android app not reading picture location data

Thanks so much! Your workaround works for me, too (sharing from photo to iNaturalist app).

No location just started happening (Aug 29, 2023) to me with a Samsung Galaxy S22 Ultra. Photos have location information, but suddenly stopped showing up in iNaturalist version 1.29.5 (579).

1 Like

I am also on a Pixel 4a and had been having this problem. The workaround is working for me! Thank you for getting this fixed!


Platform Android

App version number 1.29.5 (579)

Smartphone Xiaomi Redmi Note 10 Pro

Description of problem
Step 1: Start new observation with “choose image”

Step 2: choose image

Step 3: no location recognized from metadata

Another bug resulting from the recent changes to uploading photos in the app (fourth one following

I’ve tested, coordinates are present in the metadata, if to upload the same photos in the browser version of iNat it recognizes location from the metadata, but the app is not recognizes them anymore (it was always working).

I’ve tried to reinstall the app, it has all permissions.

I can actually say for sure that it’s from the update that was installed on my phone on August 26, it stopped to indicate coordinates in the metadata of photos uploaded in the app:
So it destroyed the verifiability of all observations uploaded in the app since.

I’ve also noticed this issue and I’m using a workaround now. I choose a longer path to enter my phone gallery: Add → Choose Image → “three dots” → Browse… → Gallery → (choose photos from here).

So now, photos chosen from the phone gallery (deeper path) transfer gps data to iNat. Photos chosen from a catalog directly after “Choose Image” lack these data.

1 Like

this appears to be the same thing as: should probably be merged.

It’s not the same because it’s from the most recent update, it was perfectly working before 26 August 2023, including in December 2022

as i understand it, the issue manifests itself as a result of a change in Android itself, not in the iNat Android app. so you probably got an Android system update on 26 Aug, and that’s what caused the iNat app to start not working for you. as far as i know, the iNat app has not yet been updated to handle whatever the issue is, but you can work around the problem using the suggestions in your thread here and in the other thread.

1 Like

As far as I know, most of them are regular iNat users, but the difficulty with testing for these kinds of bugs is that most of the time they are specific to a particular model of phone, say, or only affect files that have been edited with a particular app, or only occur under a very specific set of conditions such as on phones with a particular default language, or whatever. As such, the bugs that make it through to the final version are almost always ones that only affect a small proportion of users, and so are not easy to stumble across just by a few people doing random checks.


Merged as this seems to be the same issue due to change in Android photo picker.

I do not think the merge is in order, something definitely happened! The picker is not unusable, but it works perfectly in PlantNET on th esame phone!!!

I opened a new report for that

No, it isn’t, other apps, like PlantNET, on my phone still get a better photo picker. Maybe they will also use the bad one when I update them, but I do not have automatic updates enabled as often that leads to problems like this.

I’m not sure what I can add to what I’ve already said. This is due to the Android photo picker being changed. We and others (including someone from PlantNet, a few weeks ago) asked Google to have the picker include GPS data, but they’ve said they won’t do it. I don’t know what other apps use, maybe they use a built-in picker they’ve made themselves, which is something we will likely have to do in the long term, but that takes time to make/change. We’re working on a solution but it’s not ready yet. In the meantime, there are two workarounds to address it:

  • go to your phone’s gallery and share photos to iNaturalist from there

  • click on the three dots in the new photo picker (right-hand side) and choose “Browse”. That seems to fix things.


I recently wondered why my observations were all in the Gulf of Guinea and required manual correction, now I know why (it seems to be a strange new “feature” in Android which requires separate permissions to read Exif data from pics where the permission to read the image itself is already present). The workaround works.

Inat 1.29.5 (579)
A53 5G (SM-A536B/DS)
Android 13, last update 2023-08-03

A new Android update was just offered (2023-09-01), I installed it.
It got worse, now the workaround also ignores the coordinates from the image.

With Plantnet, the builtin picker is also broken but the workaround still works (after the system update, didn’t try before).
Compare and

Interestingly, Plantnet actually complained about this issue (most recent comment on it):
So this is an issue that extends across similar apps.

2 posts were merged into an existing topic: The new Andoid app version now uses a very restricted photo picker

This is so frustrating… I just went and read the issue over on Google and it’s bizarre how they’re not recognizing that many, many people have very legitimate use cases for pulling this data!

@tiwane and others, just wanted to say thanks for looking into this, and for posting the workaround (works for me for now, on Google Pixel 6). Hoping for your sake that Google is able to get this resolved, or that they decide to stop being obstructionist about it. Let us know if there’s anything we, the iNat users, can do to help convince them.

I actually found out that the “share” workaround results into a faster workflow, because one does not have to scroll through the large collection to find the location where one was a minute ago all the time. I hope it will remain functional but with Google one never knows, they do what they can to be the only ones to have the consumer data that they can sell.

Having the same issue but it only started recently.