App not responding when I try to add photo for observation

I am using an LG android. Two days ago it started having problems when I try to add a photo for observation. When I hit add image, it either

  1. just hangs on the white screen for a very long time and either crashes, or
  2. finally shows images from my photo gallery after a long pause.
    In addition, I have also been having the problem when I add an observation, it enters two identical ones.
1 Like

Which version of the app do you have? Can you please share screenshots of what you’re seeing?

We ask these questions up front for new bug reports because they’re often necessary for us to investigate the bug.

1 Like

I believe I have the same problem. I recently upgraded to Android 11 and then saw the problem. When I take a photo to start an observation, I get the Camera app and can take a picture. However, when I accept the photo, the iNaturalist app appears to crash and then restart. This causes an empty observation to be put in my upload queue.

I hesitate to say ‘me too’, but I just upgraded to Android 11 on a Pixel 3a, and the iNaturalist app crashed just after clicking on the check-mark after having taken a photo. I did click the ‘send bug report’ – but I don’t know if the dev team gets access to those.

This is version 1.20.11 (442)

I can replicate this after updating to Android 11 on my Pixel 3a as well. We’ll take a look.

1 Like

OK, there are fixes in the latest beta version (1.20.16 (447) ), and we’ve started rolling it out very slowly to the Google Play Store to look for crashes. If you want to try out the beta version now, go to https://play.google.com/apps/testing/org.inaturalist.android