App Slow to Sync, Progress Bars Hang (not smooth), Provide No Info On What's Going On

Platform (Android, iOS, Website): Android

App version number, if a mobile app issue (shown under Settings or About): 1.23.4 (493) (Just updated to newest version, problem unaffected by update)

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

When I record new observations (i.e. I take a few new pictures when out, save them to a few new observations, and then come home to sync them when I am connected to WiFi so I don’t use my mobile data), they are painfully slow to sync, and they do so in a “jerky” or “blocky” fashion. Often, the app just sits there saying “Syncing” and doesn’t show any sign of progress bars uploading anything, nor does it give any explanation of what is going on. When it does show progress bars, instead of showing smooth progress of an upload, it just has the circular progress bar appear, and often it jumps 1/3rd of the way or 1/2 way and then just hangs there, sitting there sometimes for minutes. There is no “smooth” display of progress, even when I have the app open and am looking at it.

I have background data use disabled for all apps, including iNaturalist, because I don’t want to walk out of wireless range and have the app start eating up my data trying to upload these huge pictures. So this may be a factor. But I want to be able for it to sync normally when the app is open. This problem still exists even when I have the app open and am looking at it the whole time.

It’s frustrating to me because I have to sit here with my app open waiting for 5 or 10 minutes and often then it doesn’t even sync. Often, the sync just halts or interrupts but without giving me any sort of error message or indication of what is going on. I sometimes have to repeat the sync process 3 or more times in order to get it completed.

Sometimes, the app makes me re-sync already synced observations, with no clear explanation of why.

And throughout this whole thing there is no actual sign of progress or no communication with me, the user, about what is going on. Instead of a smooth progress bar, the bar just goes from 0 to like 50% and then just sits there. I understand that there are all sorts of constraints you are working with, but from my perspective, I’m not being given the information to help troubleshoot the problem:

  • If the sync is hanging because there is a server problem and the solution is for me to try again later, I want to be told that.
  • If the sync is actually progressing, I want the progress bar to show that instead of it just sitting still for minutes and then jumping to 100 or jumping to the next observation. I especially want it to display smooth progress updates when I have the app open and active and am looking at the screen.
  • If my internet connectivity has temporarily cut out (perhaps from walking too far away from my WiFi transmitter, or some other reason, which I can troubleshoot independently of the iNat app) then I want to be told this.
  • I never get any notice of errors or explanations of why a particular record failed to sync, or even that it failed to sync. Instead, it just syncs again or displays as needing sync.

My internet connection is really fast, I’ve tested my upload speed. I’m able to upload these large image files in seconds to places like Google Drive, with no issue, so I suspect it’s not my connection unless I happen to have had intermittent connectivity problems that did not coincide with when I tested uploads to Google Drive.

As a side-note, the progress bar for uploads on this forum work beautifully. If you could get the app to behave like the forum’s upload system, that would be fantastic, as it’s super smooth and I can see the progress progress gradually as the file uploads.

1 Like

The speed and fluidity of progress bars vary depending on the files and uploader. I recommend reading this article for a detailed explanation for why and how they sometimes don’t seem helpful:

Eh, I’m skeptical that this explains it.

Even with my fast connection, I seriously doubt that my connection is fast enough to be able to transfer the image files for a single observation instantaneously. These are big files, like many megabytes, some over 10MB. Yet the progress bar (or rather, circle) advances instantaneously, in fits and starts, and then hangs there for an extended period of time.

Even if it were updating file-by-file, it would advance in steps, which it does not do. Sometimes there will be a single observation with 3-4 images and it’ll either jump directly to the next observation, or maybe jump to the halfway point and then again jump to the next one.

The behavior is strange and unintuitive to me and the explanation on the linked article doesn’t really make sense for what is going on here.

Hmm… I guess the progress bar here is just made manually, not meant to be exact?

I’ve been fiddling with this and it looks like the progress bar actually does upload smoothly and I wasn’t noticing it because my connection is really fast. But it is still hanging.

Lately it’s been so bad that I have been unable to sync more than 2/3rds of the time, i.e. it just hangs for minutes and I have to interrupt it, I try again later.

This past time I was able to sync one of three observations but the other two have been hanging there and I’ve tried maybe 5 or more times…tried closing the app and restarting to no avail.

I’d feel so much better if the app would just give me an error message as a courtesy. I get that there are a ton of variables in file upload and it can be hard to program and a lot of different things so wrong, but even a generic error message here would be an improvement.

I tried it again now and it’s doing the same thing, fits and starts, long periods of hanging, it got through one observation and is now stuck on the second one. We’ll see if it completes or not.

There is definitely a syncing bug in 1.23.4 (493), although I cant be sure it’s causing this particular issue. We just released a beta version that should fix this, if you want to try it out. What the fix should do is sync all the unproblematic observations that are being held up by the one(s) with the error. I’d be interested to know if it does this with your device. You can become a beta tester here:

This bug we’ve been investigating is caused by editing the photos of an existing observation and/or changing their order. Do you remember if you did that around the time this issue started? Either way, what we really need are log files from you app after you experience the issue.

To send log files, go to the About tab in the app and tap three times on the version number. You will then have the option to email the log files to us.

Just to clarify, the mobile app resizes large photos to no more than 2048 x 2048 pixels before upload, so I don’t think it’s ever sending 10mb image files.

1 Like

That makes sense and sounds like a very good thing!

No, I have not edited any of the photos of existing observations or changed their orders. I have rarely or never used this feature in the past, and I have certainly not used it recently, not in the time-frame when this problem cropped up.

Any updates on this issue? I am still having it and have noticed no improvement whatsoever.

It is deterring me from making observations, because the more observations I make, the more I have to continually re-open the app.

Until this is fixed, I will likely make few observations, choosing only to be very selective about stuff where I want something out of it (like a community ID) rather than trying to observe stuff for reporting’s sake, more or better photos, etc. And this makes me sad because I really like contributing to citizen science.

6 posts were split to a new topic: Using the iNat website to upload phone camera observations when the app isn’t working