Batch edit for list is removing only one "with errors" at a time

Platform (Android, iOS, Website): website

Browser, if a website issue (Firefox, Chrome, etc) : chrome

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/lists/4411198-Unobserved/batch_edit?flow_task_id=336232

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): The problem arose from uploading a csv file for creating a list using the batch edit. The file has a couple different kinds of errors: “taxon already on the list” and “taxon can’t be blank”, but the errors themselves were over 3,000.

Step 1: Select “with errors”

Step 2: Click “remove”

Step 3: Click “ok” to “Are you sure you want to remove these taxa?”

Result: Only one error gets removed. I tried selecting only a couple dozen errors in case the problem was having selected too many, but got the same result. One deletion at a time.