Camera response still poor within app

Platform: iOS

App version number: 3.0.4 build 607

Screenshots of what you are seeing:

Description of problem:

Step 1: When using the app to make observations:

A. I often have to hit the camera icon several times before anything happens.

B. When in the camera mode, trying to zoom in, I have to make the zoom in gesture several times before anything happens, then all of a sudden I am zoomed in, too much zoomed in.

Step 2: When trying to put an ID on an observation, when I tap on the one I want to work on, often nothing happens, so I tap on it several times, and then all of a sudden it opens several versions at once.

As you can tell, these all appear to be the same sort of problem.

1 Like

Which device are you using, and which version of iOS is it running?

In iOS, I sometimes get such a missed or delayed tap reaction. In my case, it happens with a number of apps, tho. I usually reboot to see if it improves. Usually, it does. But, although the symptoms sound similar, I realize it could be completely different in my case.

1 Like

Thanks. Details like device and which version of iOS you’re using would be helpful information for us to have.

An iPhone X which is currently running iOS version 13.7. I can change to 14.1, but someone said that that is very buggy so I was not sure if that would be a good idea.

1 Like

Thanks. I just went out and did some testing with my iPhone XS, running iOS 14.0.1 and didn’t have any problems with Step 1 from your original post. I have encountered Step 2 sometimes, but that seems unrelated to the camera. Here’s a short screen recording of me using the camera:

If you want to make a screen recording and share it here or email it to, that might be helpful. Here are instructions:

How much space on your phone is iNaturalist using?

Did you mean to reply to me? I am not the OP.

In my case, I didn’t really consider it an iNat issue; so much as an iOS quirk. Restarting the phone usually helps for me. FWIW, iPhone 11 PM, iOS 13.6.1, iNat 2.8.7.

1 Like

Today I updated to the latest operating system for my iPhone X. I also deleted the iNat app and downloaded a fresh one from the app store, thus clearing my cache.

But when I try to log in, the app tells me I have the wrong name or password.

And each time that happens I try to make a new password, but I am told that the current password token is no good any more.

So I can’t use the app at all right now. But the website works great and I am still signed in there. Is that the problem? Should I log out of the website?

Just now I tried that, and made a new password and could get back into the website OK but still can’t get into the app

What do you think I need to do now?

This is urgent because I have a shell I want to photograph that I brought home yesterday, and plus I need to keep my streak alive.

This has came up yesterday from a user, but I couldn’t replicate it - I was able to make a new password via the app just fine.

Unfortunately I think what I’d need is a painfully detailed step by step walkthrough of what you did, including screen shots of error messages. Perhaps I’m doing something that you and the other user are not doing.

I can’t tell you up to now what I have done and seen, but I can tell you what I do now, and what I see.

A fe minues ago I could not even get into the website OK because it would not accept my password or a new one. But just now I could get into the website OK – I tried to log in and it took me to my page and said “You are already signed in”.

As for the app, I am currently on the re-set password page and the error message says:

There were problems with the following fields:

  • Reset password token is invalid.


On the app I get that error message every single time I try to create a new password. I can’t log onto the app with any password that I try to create.

Can you please post screenshots? Screenshots often provide a lot of clues that descriptions simply can’t cover.

So, using version 3.0.4 on my iPhone XS running iOS 14.0.1:

  1. I tap on Forgot Password on the log in screen.
  2. I go to this page and enter my email address, then tap on Send me reset password instructions.

  1. In the email I receive, I tap on the the link and get taken to this page, where I enter the new password twice, then tap on Change Your Password.

  1. I’m logged in to the website.
  2. I open up the app and log in using my username and new password. I got one error message saying “Incorrect username or password” then I tried again and was able to log in.

Thanks! Somehow magically it listened to you, Tony, and now everything is working again!!!

1 Like

Does that mean the camera is working OK as well?

Yes I think so. Let me take it out in the backyard and give it a whirl.

1 Like

Yes, it seems all to be fine now! Thanks. Maybe updating the operating system helped…

1 Like