Can accidentally select previous observations when trying to edit a new observation (Android)

Platform Android

App version number 1.20.22 (has been present on every previous app version I have used)

Screenshots of what you are seeing Not sure of easy way to show my issue with screenshots, especially since this is a mobile issue. Will describe how to reproduce, though.

Description of problem When cobbling together a new observation, if I press within the image add/edit portion of the screen, I can sometimes for some reason select behind the panel into the observations screen and the only way to exit is to go back to the observations screen, which automatically submits the observation.

Step 1: Press within the area used to add/edit images in observation details screen.

Step 2: This will sometimes automatically bring up a previous observation within the top 3 panel of observed life, interrupting the editing process. The only way to resume is to wait for the observation to finish submitting and then re-edit.

The only way I’d see for this problem to be solved is for the interactive layer of the main observations screen to be entirely disabled when viewing or editing a listing.

I am not entirely sure if this can only be triggered when making a new listing or when editing existing ones. It has happened to me when creating a new listing.


I don’t regularly use the Android app so I haven’t experienced this. Has anyone else?

@manedwolf, if it happens again can you please send us log files from the app right after? Not sure if they’ll show anything, but it’s worth a shot. To send log files, go to the About tab in the app and tap three times on the version number. You will then have the option to email the log files to us.

1 Like

Alright. Will try to do the next time it occurs.

Just happened to me now, tried to add photos to observation, but somehow got two previous observations opened in edit mode one after one quickly, first observation started synchronizing.

1 Like

Haven’t had it happen to me again yet, but I have not had as many observations lately (so no need to add them too quickly). Interesting to see it is still happening for other users. Hopefully this is a simple fix.

It happened to me yesterday evening, so it’s still there.

1 Like

We think this is related to a recent feature that allows you to swipe left or right on the Details (aka edit) screen to move to the next observation. Not something I’ve ever used and not something I’d miss, but perhaps others use it? Anyway, two possible fixes:

  1. Remove the swipe feature altogether.
  2. Don’t allow the upper part of the screen (where the photos/sounds are displayed) to be part of the swipe feature.
1 Like

If this is the case it seems like the real issue is that the swipe feature completely ignores when you’re editing, and what you’re currently interacting with. Number 2. could be a fix but it seems like it could still cause the issue to persist if the code isn’t absolutely perfect. I’m just not sure what the point of this feature is in the first place, so deciding on the fate of it after a poll of if people find it useful or not could be the answer. Not sure how these decisions are made on the developer end but it would be nice if the user base is included.