Can't upload observation/photos

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website):


App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) :

Tried it with Chrome and with Firefox

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

I am trying to upload two pictures for creating an observation
First it says loading metadata – and then after a while the pictures disappear as per second screenshot

When I create then the observation it misses then the pictures.
The picture sizes are 1 mb and 3 mb
I already sent an email including the two pictures to this Wednesday but didn’t got yet a reply


ok tried it now in Edge and it worked :)
also retried a different set and it worked as well now in Firefox

1 Like

It sounds like it could be an issue with Chrome extensions - you can try turning those off and seeing if the upload works and isolating the issue that way.

1 Like