Pictures upload failing when creating a new observation via web browser

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): macOS Monterey 12.5

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Safari Version 15.6 (17613.3.9.1.5)
& Chrome Version 104.0.5112.79

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/observations/upload

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Since yesterday I’ve had increasing difficulty getting the pictures to upload for new observations. It seems somewhat sporadic, but is currently more likely to fail than not. I usually use the Safari browser, but have tried using Chrome with the same results. (have also tried using incognito mode which doesn’t help.) I have inaturalist.org as a trusted website in my browser preferences The picture in the example screen shot is 10mb in size. I shoot in RAW, and export from Lightroom as a jpeg. I’ve tried exporting as a small jpeg instead of full size, but that doesn’t seem to help, nor does changing the export to NOT include all metadata. Sometimes I just try multiple times and eventually it uploads.

Step 2: I imported the above pic into my photo library and then used the iNat app on my iPhone 10X and it loaded. https://www.inaturalist.org/observations/130998591
Several others that failed I also went through this process with success:
https://www.inaturalist.org/observations/130886829
https://www.inaturalist.org/observations/130929048

Step 3: Any help advice is appreciated. I definitely don’t wish to start having to use the import to photo library/use iPhone app method to add observations.

Thanks in advance, John

Can you please email or dropbox/google drive some of those photos to help@inaturalist.org?

I’ve emailed the pics for those three observations. (2 emails)

2 Likes

This is just too weird. So I’ve been trying different approaches on my end to see if I could determine what the issue may be. I was leaning toward a failure in the iNat system that takes the original and resizes it to make it acceptable. The screenshot below shows four exports of the same picture. From left to right:

Pic one (that failed) was full size export that was renamed.
Pic two (that succeeded) was default small export that was renamed.
Pic three that (that failed) was custom export of long side = 7" that was renamed.
Pic four (that succeeded) was full size BUT not renamed. What???

Also, Repeating this cycle with different pics does not always give the same results. SMH. - John

I tried the photos you sent me and couldn’t replicate the issue in either Chrome or Safari. Have you tried turning off all of your browser’s extensions and importing the photos? That’s a good way to see if they’re the cause of a problem.

If you do that and there’s still an issue, can you please open up the browser’s console and include a screenshot of it after some photos fail? Hopefully it will record some errors.

This page has instructions for how to view the console for the most common browsers: https://support.airtable.com/hc/en-us/articles/232313848-How-to-open-the-developer-console

1 Like

The only extension I use in Safari is DuckDuckGo. I have it turned off for this troubleshooting, but turning it off had no effect. Here is the what I get in the JavaScript Console when I tried to upload a single pic just now.

[Warning] Deprecation warning: value provided is not in a recognized RFC2822 or ISO format. moment construction falls back to js Date(), which is not reliable across all browsers and versions. Non RFC2822/ISO date formats are discouraged. Please refer to http://momentjs.com/guides/#/warnings/js-date/ for more info. (observations-uploader-webpack-f6f5dfe8a17628099e31817a3e2ff2f149bcc69eae33e6e4d5b978a6c76ff2b3.js, line 17)
Arguments:
[0] _isAMomentObject: true, _isUTC: false, _useUTC: false, _l: undefined, _i: 2022/08/16 14:57:20, _f: undefined, _strict: undefined, _locale: [object Object]
@https://www.inaturalist.org/assets/observations-uploader-webpack-f6f5dfe8a17628099e31817a3e2ff2f149bcc69eae33e6e4d5b978a6c76ff2b3.js:17:4212
configFromString@https://www.inaturalist.org/assets/observations-uploader-webpack-f6f5dfe8a17628099e31817a3e2ff2f149bcc69eae33e6e4d5b978a6c76ff2b3.js:17:30786
configFromInput@https://www.inaturalist.org/assets/observations-uploader-webpack-f6f5dfe8a17628099e31817a3e2ff2f149bcc69eae33e6e4d5b978a6c76ff2b3.js:18:4460
prepareConfig@https://www.inaturalist.org/assets/observations-uploader-webpack-f6f5dfe8a17628099e31817a3e2ff2f149bcc69eae33e6e4d5b978a6c76ff2b3.js:18:4215
createFromConfig@https://www.inaturalist.org/assets/observations-uploader-webpack-f6f5dfe8a17628099e31817a3e2ff2f149bcc69eae33e6e4d5b978a6c76ff2b3.js:18:3678
@https://www.inaturalist.org/assets/observations-uploader-webpack-f6f5dfe8a17628099e31817a3e2ff2f149bcc69eae33e6e4d5b978a6c76ff2b3.js:1023:14107
[Error] Failed to load resource: The network connection was lost. (photos, line 0)

1 Like

This is happening to me too. Very strange.

1 Like

what you’re describing here sounds like a case of a flaky internet connection. what kind of internet service are you using? are you noticing signs of a flaky connection when visiting other sites or using other apps?

3 Likes

That was the first thing I checked and have continued to monitor. I have 1 gb broadband service with a 1 gb access point about 12 ft from where I work. Although my MacBook Pro is not capable of 1 Gb WiFi, I generally see 600+ mbps download and 30 to 40 mbps upload speeds. I’ve had ping running in the background during this process without a single dropped packet or excessive response times. I use LightroomCC for photo editing and can upload 100-200 gb of RAW files smoothly and relatively quickly.

It also usually happens to me when my internet connection is unstable

if you get a chance, it still might be informative to see if you have more reliable observation uploads using a different internet connection.

At least it isn’t just me. I’ve just tried to upload 12 pictures at 4pm BST (UK) and EIGHT have failed. All original untouched jpegs.

I too suspect a weak internet service.

Has anyone tried uploading very early in the morning or late in the evening to see if it helps.

2 Likes

Early morning and late evening is usually when I do my uploads. Doesn’t seem to make a difference either way. I’m pretty well convinced my issue isn’t with my internet service, but I’ve been wrong before. It was on a Friday…

1 Like

Have y’all made any progress on your end? There were updates for the macOS this morning (12.5.1) which I applied on my MacBook Pro and my iMac. There were also updates to Creative Cloud Control, Adobe Lightroom and Photoshop which I applied. None made a difference. I don’t normally use my iMac for submitting observations, but I did try it this morning and had the same upload failures as my MacBook. Also tried changing the DNS from Spectrum’s default to Google’s 8.8.8.8 and 8.8.4.4. Didn’t help. Still showing high and constant download speeds upload (600+ mbps up and 40 mbps down.) Running ping in the background still shows no dropped packets, and low, stable response times. And my uploads to Adobe cloud are fast and worry-free. Seen anything in your server or firewall logs?

I have found a workaround for now. I export my full size jpeg 4 times per pic and try to upload all four. More often than not one or two will succeed, so I will delete the failures and extra succeeded not needed and submit my observation that way. Very cumbersome and unsustainable for the long haul, but keeps me from being shutdown completely short-term.

Let me know if there is something else you’d like me to do on my end. - John

1 Like

assuming there’s no difference between the notebook and the desktop, then i would think the problem is still most likely your internet service. if you’re hesitant or unable to test an upload from a different connection, you could try instead loading through a VPN to see if that makes a difference. (if you don’t already have a VPN service, i think you use something like the Opera browser, which includes a VPN service as part of the product.)

1 Like

I have exactly the same bug on Mac Os Big Sur 11.3.1 with Chrome 104.0.5112.101 and Safari 14.1…

I encounter similar problems when my internet is laggy. But nothing unless the internet is not working.

Reporting the same issue: since August 18 I am completely unable to upload observations via the web browser interface.

Issue replicated across multiple browsers:
Firefox 103.0.2
Chrome 104.0.5112.101 (Official Build) (arm64)
Safari 15.6 (17613.3.9.1.5)

Mac OS 12.5

It has been a while, but I have had the same issue in the past on different occasions. Sometimes the pictures upload correctly, only to see some disappear when curating others from the same batch. My guess is/was that was due to either a flaky internet connection of a memory issue.

I could have always solved the issue by restarting with fewer images (i.,e. dividing in multiple upload sessions)

Anyone experiencing this: have you tried turning off browser extensions and then uploading? It would good know if any specific extension is causing this, or to eliminate that as a possibility.

Also, the next time this happens please open up your browser’s console and share a screenshot that includes the console. Errors in the console could provide clues as to what’s happening.