Colour in guides is in two groups

In the Guides I have tried to add colours but white is not grouping with the rest of the colours, Why? has two “Colour” fields which is probably the source of the issue. Not sure how to resolve it.

It looks like the category for white is Colour, while the category for the rest is colour – I guess it’s case sensitive. Try making the category for white colour.

1 Like

Please note that this is not an input error - white is added the same as any other colour.


It may be the case that the error is from iNat, not from you, but since Guides are not getting any more updates, the best solution may be to try to fix it from your end.

If you go to the edit page, what do the tags look like? Is there a capital C on Colour for the white tag? I spent a while trying to replicate this, and the only way I could get it to replicate was to misspell white. Is it possible there might be an extra invisible character at the end of white in your csv?
At any rate, the fix for me was to delete the white tag and add it again correctly spelled. I would suggest you try removing that tag using the Guides interface, then add it back by manually entering it.

i encountered this quirk back a couple of years ago when trying to create some guides from CSV. if i recall correctly, it seemed like “color” (for me, since i am in the US, i assume), was a reserved tag. so if i used “color” as a column in my CSV, i would get weird results. the way i worked around it was to use “flower color” or “plant color”, etc.

Thank you for the feedback. The American ‘color’ works. Thank you

if “color” works for you, and you really want to use “colour”, you might want to try switching your language preferences to US when creating your guide.

I’m glad it works, but I hope you didn’t interpret what I said to mean that “color” is the correct spelling! The spelling I was fiddling with was for the color name itself – I got the bug to happen when I used “whaite” instead of “white”.

I did not interpret it like that. I am happy that it works and I am not fazed how it is spelt. Thank you.