Community ID bug with subspecies

Why is the community ID here not the subspecies I selected: Seems like a bug to me.

1 Like

Here’s another observation with a bad community ID:

I believe because, while the taxon you’ve suggested is within the higher level taxon, it’s not the community consensus.

From the about section on Community ID:
“For example, if you think its a snake (suborder Serpentes) and I think it’s a kingsnake (genus Lampropeltis ) the observation taxon will be at kingsnake (supported by my identification only) but the community taxon will be at serpentes (supported by at least two identifications).”

You have suggested an ID but the general consensus only holds out at a higher level so it’s set to that.

1 Like

If you click
What’s this?
at the Community taxon, I am impressed that iNat spells out for every single observation how and what they are counting! You need two votes to agree for Community ID.

Both your examples are staying at the higher level agreement.


Here’s another one that seems buggy somehow and involves a subspecies id

Subspecies IDs don’t move the Observation Taxon forward like a species ID does.

In your first case, if you IDed to species, the Observation Taxon (what is displayed at the top of the page) would be Faxonius palmeri, but the Community Taxon (on the right side of the page), would still be Astacidea.

See this relevant feature request:


I ran into this issue again today. The link you give says the issue was closed because its already on their radar, but that was February. Has it fallen off the radar. Pardon my frustration, but this seems crazy bug that needs to be fixed now. This is not a feature request, its a bug affecting a large number of observations.

Here’s the latest case. Someone posts a Cicada. I ID as Neotibicen lyricen lyricen. The community ID is still Neotibicen. So I delete that ID and ID as Neotibicen lyricen. That give a good community ID. Then I seemingly refine it by IDing it to the subspecies. The community ID reverts back to Neotibicen.

I agree that it needs to be addressed. But, it’s a small team and they’ve got a lot to work on with 3 apps and a website.

Here’s another crazy one. Someone IDs to genus. Then I give a subspecies ID, he withdraws the genus ID and agrees with my subspecies, but the community ID is still the genus:

why can’t they just revert to the old community ID method, since it worked better than the current one?

This one isn’t because of subspecies. It’s yet another instance of a recent bug affecting all observations where the date observed is after the date uploaded.