Donate does not work

I am using Google Chrome to reach the website and get the error message below when I try to donate. Clearing the cache does not work.


1 Like

Hi @cathyp, which page are you starting from, and where exactly are you clicking? There is a message that people see on the homepage when they are logged out, and a different one if you’re logged in (on

Edited to add: there’s also a donate button in the footer, in case you’re trying that.

1 Like

All of the options to access Donate work for me in Google Chrome Windows. Did you reboot your computer and try again?

Do you have the Duck Duck Go extension installed in Chrome? Someone yesterday couldn’t load the Donations page due to that extension.

1 Like

@cathyp are you still unable to load the Donations page?

1 Like

I use as Browser Firefox 91.4.1esr (64 bit) over Linux Debian 11 OS
The page doesn’t run.

Have you tried turning off any extensions? I don’t have a Liniux machine but it loads fine for me with the latest version of FF for Mac.

1 Like

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages:,

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): I’m trying to become a monthly donor and the page simply does not load for me. It’s definitely not an issue with my internet as everything else loads just fine and this issue has persisted for weeks. I’ve even tried disconnecting from my VPN but that doesn’t work. The page just does not load and then says “too many redirects” and stays on the page that I attached a screenshot of.

It’s really disappointing because I want to give you guys my money and its just not working.

Step 1:

Step 2:

Step 3:

@gambel I moved your post to this existing bug report. As you can see you’re not alone here, but no one at iNaturalist is able to replicate this issue on our end. Do you have any extensions installed in Chrome? If so, can you please turn them off and see if that works? Are you able to load the page in any other browsers?

Also, thank you to everyone who’s donating (or trying to donate) to iNat, we really appreciate it!

Just disabled the duckduckgo extension and it works now. Thanks!


OK, since others encountering this problem haven’t responded I’m going to close the topic.

If it’s Duck Duck Go or something similar that’s causing this, it’s likely because we do track which donate buttons lead to donations, and that’s why the Donate button on the footer at is “” So we’ll know the donor got to the donate page by clicking the button in the footer. You’ll see similar things on most other sites with a donate button.

1 Like

Here’s a potential change to fix this issue.

1 Like