images & statistics not loading in Chrome

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform: Website (Windows PC)

Browser: Chrome


Screenshots of what you are seeing:


Description of problem:

Recently, when I log in on the site using a regular Chrome tab, images are not loading. None. I can open the links to images in a new tab, however they do not display in the webpage. None of the images display, even logos. This was not the case until a little over 1 week ago.

For example: – I can open this in another tab and it displays normally. But per the screenshot, it is not displayed.

I have none of these problems using the site in a regular Chrome tab.

When I open an incognito / private browsing tab in Chrome, I the site works normally; all images are properly displayed. Logging in on Firefox, I also have no problem.

YES, I have tried clearing the cache in Chrome. Twice. 198 MB → 0 MB. This has had no effect on the loading.

Additionally, it appears that accessing taxon pages on the site, database queries aren’t happening, as no observations nor observers are listed. The lack of stats suggests to me that it’s something on the server side… or something really weird.

1 Like

Can you please open up the developer console on one of these pages (Tools>Developer>Javascript Console) and post a screenshot of it?

I hope that this is what you’re looking for. Let me know if I’m looking at the wrong part of the developer console.



1 Like

Your incognito window shows your extensions disabled. I suspect one of them is causing your problem, I would try turning them off one at a time.


Agree, “client” means you, so ERR_BLOCKED_BY_CLIENT means something is being blocked on your end.

Looks like @tiwane and @jwidness are correct here. I’m not sure why it worked for so long & eventually stopped, but it appears that one of my Chrome extensions was the key to fixing this problem on my end.

For anyone else encountering this, the extension that I have is called “Privacy Badger” by the Electronic Frontiers Foundation. It was fixed by adding the iNaturalist to the list of excluded domains (“Disabled Sites”):

Appreciate the help!


Ah, yeah, that extension has been the culprit in other cases. Thanks for the helpful reply @murphyslab!

1 Like