Email address confirmation required but no confirmation emails ever arrive

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): website

App version number, if a mobile app issue (shown under Settings or About): n/a

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Log in to inaturalist.org
Step 2: See banner at top
Step 3: Follow instructions to send email and log out
Step 4: No confirmation email arrives, not even in my spam folder

Can you please try again? There was a bug that’s now been fixed. I was just able to confirm my email address.

2 Likes

Same here and now I am locked out. The only message I see at the top of the page is to click the link in the email that never arrived. Please fix this!

1 Like

welcome to the forum

did you try the process again as per Tony’s comment above?

1 Like

‘’ Our mailing address is:‘’
Not all items are translated in the conformation mail…

@rahopko’s issue was not related to the initial bug. I was able to confirm the email address.

1 Like

It’s working now.

2 Likes

I’m having the same issue.

I did check the email address was correct before proceeding but still have not recieved an email. Checked spam folder etc. But nothing there.

Cheers Alan

SEE MY UPDATE POSTED BELOW:

2 Likes

Signed up for the forum finally after being an iNaturalist member since March of 2020. Thought I’d add my report of being locked out after the email address confirmation. Sent an email to the inaturalist.org address sharing this concern without response so far. Anything further I should do? Did immediately receive an email confirmation for this group. When I attempt to sign in, “Please check your email and click the link in the email you received to confirm your account.” appears in a yellow box over the featured picture. No email for the confirmation has been received yet.

Same issue with user @harshithjv.He has locked out now.Neither getting email nor able to login now.

1 Like

Hi, I have the same problem. Only now I can’t redo the process and ask for a confirmation email. Where can I ask for the email with the confirmation link? Thanks

Similar issue (gmail, Google Chrome, MacBook Pro). No confirmation email has arrived. It’s been about 30 minutes. :)

Thanks @firos_ak . My issue is resolved now as the email was in different as I’d redirected all my email from inaturalist to differrent folder and also archived it. Now I reinstated with the account.

1 Like

I am having the same issue. Sent the email. I have logged out of my email account a few times and still no email. I am now locked out of iNaturalist? Not sure the bug is fixed or the problem addressed. Seems that way. Thank you.

Yahoo mail. Apple Macbook Pro. OS: Ventura 13.0.1 Browser:Chrome

If I can’t log in, I can’t go to my account settings. I am unable to reset my password and am now locked out.

If you don’t receive an email, it’d be best to email help@inaturalist.org. Since your email address is part of that email, it’s easier for us to investigate. It takes longer to get someone’s email address here on the forum, and that’s really the information we need to look into it.

3 Likes

Hey thanks for getting back to me. I hope my contact through email was appropriate. If not, I apologize.

1 Like

I just tried searching “confirmation instructions” in my email and the message had been labeled junk and deleted. I don’t usually have this sort of problem with gmail.

Same thing here, I tried many times and there’s still no email arrived. Now I can’t use iNat.

@tiwane - When I click “Send and Sign Out” it neither sends the email, nor signs me out (luckily). I do, however, get the following console errors (using Chrome on MacOS):
PUT https://api.inaturalist.org/v2/users/13405 422 (Unprocessable Entity)
Uncaught (in promise) TypeError: Cannot read properties of undefined (reading ‘original’)
at _callee2$ (users-edit-webpack-fe320120db8c4eb53d15b5d4ec7c2e64bc681894c0cf2fa42964912e8a67654e.js:959:16730) …
I get the same errors if I click the “Save Settings” button as well.