"Failed to save record" when agreeing to annotations

I’m not sure how long this has been happening, but when I click “agree” to others’ annotations (life stage and sex) on the website, it gives me a message saying (Failed to save record. Please try again later.). Could this be a problem from my end (i.e. internet connection, etc.)?

I dont think it is your issue, I am getting the same message.

This happens to me if I have the page open for a long time (say, a day) and then try to add annotations, comments or IDs. If you’ve been away from the page a while, refresh it before trying to do anything.


I do that most of the tiem, refresh before posting or doing anything, but only for annotations do I get the message. I tried opening new windows in both normal and incognito, but still doesn’t work

I signed out of the system and logged back in, so had been logged in for less than a minute, and still get the error.

This should be working now, sorry about that. Let us know if you’re still having problems.

1 Like

Yep just tried it out, it’s working now for me. Thanks for the fix @tiwane! :)

1 Like

It’s all our developers, I can’t code anything. :-)

1 Like

4 posts were split to a new topic: Why do some comments fail to be submitted, and what can be done about it?