Forum steals CNTL-f hot key!

At least on this page:
the CNTL-f hot key does not allow searching of text within the given page like is normally expected in web pages. Rather it selects the forum-wide search text area which is also opened via the magnifying glass icon located in the upper right of the page. This page is extremely long. How is one supposed to search for something in it? My only solution was to copy to entire contents into microsoft word and then search there.


I agree with you that this is annoying.
Fortunately, the browser’s menu Edit - Find still works (at least in my old version of Firefox).


That works! Thanks! I wonder if this should be considered a bug though.

1 Like

if you click the URL bar before pressing Ctrl+F, that will allow you to search the page. i don’t think it’s a bug. it’s a feature that someone thought would please more people than it didn’t.


I find if you press ctl+F twice it’ll close the forum/Discourse search and open the default browser search


For what it’s worth - the reason this isn’t a bug and an intentional choice on Discourse’s part is because on very long forum threads the forum will not load all posts at once. Rather the posts will load in dynamically as you scroll. On these long pages Discourse will hijack find so you can search across all posts in the thread, not just those that have loaded. So keep that in mind when using ctrl+f - you may not be searching the entire thread, just the posts you have scrolled enough to load


I ran into this just yesterday with Safari and command-F, and was surprised, but then realized the value and was glad that it worked this way. And for what it’s worth, I am the person who implemented Find on Page in Safari. :smile:


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.