Browser CTRL-F Overridden in Forums. Cannot Easily Override / Disable Either

I am posting here and not in Bug Reports because it is clear that this feature is by-design, but I have a huge problem with it.

When I use the browser’s search / find feature in these forums, the default behavior is overridden. Instead of pulling up the browser’s search feature, javascript captures the event and it pops up an in-page box that behaves very differently from how I want. When I use the in-page box, it changes the text displayed on the page.

It often doesn’t behave as I would expect it to. But…even when I do find the text successfully, it has then changed the text in the page so it takes extra work. It confuses me and really slows down my use and reading of threads.

I hate this feature with an extremely intense passion.

I hate whenever people override default behaviors of browsers. It’s part of a general pattern, like overriding or disabling middle-click or left-click to open links in new windows or copy link URL’s, or overriding the back button so it doesn’t behave as expected.

I have no idea why people think this sort of programming choices are necessary or beneficial to begin with. They nearly always negatively affect my ability to use a site. They are frustrating and they require me to do work to learn how to use the new interface, work I don’t want to have to do. And it’s especially infuriating to think that a programmer, probably someone who was getting paid well, put time and effort into this sort of thing. So for example, iNaturalist is run by a non-profit, and it solicits donations from users, and somewhere, someone was probably paid to create this feature that I so abhor.

Do others agree with me? Is there any way we could build a consensus to gut this feature? And in general, build a consensus behind a philosophy of web design that say that it is not okay to do this sort of thing?

3 Likes

This was discussed in https://forum.inaturalist.org/t/forum-steals-cntl-f-hot-key/14259/5

5 Likes

Thanks! I had searched but hadn’t found that thread.

It looks, however, like that thread is closed so I can’t add any comments there. It looks like there are some working solution there that will help me to get functional in-page search working again!

Thanks much!!!

2 Likes