In Identify modal, keyboard shortcuts lose focus after Lock Zoom Level

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform Website

Browser Firefox (current and past releases)

URLs (aka web addresses) of any relevant observations or pages:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: go to

Step 2: right-arrow to enter modal

Step 3: use some keyboard shortcuts

Step 4: zoom in on the map and tick “Lock zoom level”

Step 5: try using more keyboard shortcuts - no response

Step 6: workaround (minor annoyance, but still…) click mouse on a blank space in the activity pane (right pane) - keyboard focus is restored.

I’m pretty sure this is an effect of the browser, not iNaturalist. Consider what happens when you click into the comment box: you can’t use any keyboard shortcuts. The same thing happens with most other things.

1 Like

Yeah I’ve always had this issue. The ticked box is highlighted until something else is selected.

1 Like

Point taken, and reasonable for something like a comment box where typed text is the next expected input. But there is no further input expected for a checkbox, so I’m hoping iNat can do something at their end to return/maintain keyboard focus. Or otherwise, add a keyboard shortcut for Lock zoom level.

I think this is the only thing they could possibly do.

Anyway, this isn’t a bug, so, solve the thread? You could make a feature request.