Google maps not initializing

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website):

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Can’t post new observations

Step 2: Message says google maps not initializing and suggests browser, security, an extension, or ISP. I’ve cleared my Google chrome browser and restarted, talked with my ISP, don’t know how to contact Malwarebytes (my security) to check. I don’t know what to do about extensions.

Step 3: Checked inaturalist settings. What else do I need to be doing? Still can’t post.

1 Like

Another user wrote into help@inaturalist.org and said that the issue was with Malawarebytes. What happens if you turn Malawarebytes off? Or perhaps there’s a setting in Malawarebytes that allows it to not check iNaturalist?

Is it actually blocking you from submitting an observation, or just blocking you from viewing maps on iNat?

I’m having the same problem (can’t post new observations - don’t even load that webpage, and maps not working). I do run Malwarebytes, but I don’t know if that is the problem. I have noticed I’m only having this with Chrome; I tried it with Firefox and things were fine.

I have this issue now too. 1) The upload screen on desktop is just blank and never loads. In an observation within iNat it says Google Maps did not initialize.

I uninstalled my malware software. I have cleared my cache.

I did update Windows so I think this could be where the trouble is?

I have the same issue. I’m using Firefox with Windows 11. All of a sudden I started getting a message on the map screen that says: “Google Maps did not initialize. You may have blocked access to Google Maps with a browser extension or firewall, or something else is blocking access like an Internet Service Provider.”. I cannot look at the map locations for any of my observations. When I start to load a new observation the map feature will not load a location so I cannot complete posting the observation. I tried Google Chrome and the bug is not showing on there, but I’d like to get it fixed in Firefox.

Okay so I run on Google Chrome and that is where this didn’t work. I just tried Microsoft Edge and it works fine. Can anyone work out what which program is the culprit? Nortons could be a candidate.

1 Like

Glory be! checked before a day of paddling (and observation) and I now can enter observations! And, I was thinking of not taking my camera.

I had the same issue yesterday. I use Opera Gx and the Malawarebytes extension started blocking google maps only on INaturalist. Whitelisting google maps on extension settings solved the problem for me. Looking at the extension today it seems like it doesn’t block google maps anymore. They fixed it I think.

3 Likes

Mine’s working in Firefox okay now, and I didn’t do anything, so I believe it is fixed.

For anyone who can’t load inaturalist.org/observations/upload - can you please open up your browser’s console, go to inaturalist.org/observations/upload and then take a screenshot that includes the console? It should contain errors that might help us troubleshoot this.

Here are instructions for how to open Chrome’s console: https://how.sh/818-open-google-chrome-console/

Here are instructions for how to take a screenshot on several types of devices: https://www.take-a-screenshot.org

Had this issue yesterday but only with maps not initializing for observations. Did not try to upload any. I got to Malwarebytes as the culprit on Firefox, IE worked. Turning M’bytes off let maps work in Firefox. Today, no issue with M’bytes on.

OK, so it sounds like this is not affecting you all anymore? There’s probably not much we can do about it. We think this was caused by our updating to a newer version of Google Maps API, which may have triggered Malawarebytes and similar software. It’s likely that software will need to update on their end.

I’ll close this in a few days if no one’s still being hit by this issue.