"Google Maps" will not load and " +Add Observations" opens to blank page

Platform: Slackware Linux

Browser: Seamonkey (Mozilla) 2.49.4
Firefox 68.0.1esr (64 bit)


Yesterday (2023-11-15) Google Maps gave this error:

“Google Maps did not initialize. You may have blocked access to Google Maps with a browser extension or firewall, or something else is blocking access like an Internet Service Provider.”

Today (2023-11-16) “Add Observations” displays nothing - no text, no images, nothing except “Done” in the progress bar.

I had hoped this was a momentary glitch but it seems to be getting worse not better.

I don’t have this issue on Chrome. Have you tried another browser?

1 Like

I also don’t have any issues with Chrome or Firefox on Windows 10. Sounds like it might be browser specific.

Everything has been fine with both browsers that I have used here for years, until yesterday. There were similar reports several years ago which seemed to resolve themselves so I lean towards a coding issue.

1 Like

Are you using any extensions? What happens if you turn them off?

No extensions or add-ons, have tried with basic security and popup blocking disabled to no effect.

Did you ever find out what was causing this, or manage to sort it out? I’m having exactly the same problems on Android using Chrome.

Yesterday obs pictures would not load.
Eventually the issue resolved itself.


I had to install a new browser (Chrome 103.0.5060.53 64-bit). I think it may be a JAVA compatibility issue but can’t be sure. Updating your browser (Chrome, Firefox, Seamonkey) to a more current version may solve your problem.

1 Like