iNat app doesn't install from playstore

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Android

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: I had iNat installed (dont remember what version) and made quite some observations. Lately the locations were no longer loading, when I tried to make a new observation, so i decided to deinstal iNat and get the new version from playstore.

Step 2: after deinstallation, i went into playstore and tried to install the current version. Unfortunatelly the app downloads to 91% only and never finishes downloading. (Tried several times, at least 4 times stuck at 91% and never got the download completed)

Step 3: seems the iNatForum does not like to upload my sceenshot

i don’t know anything, but it kind of sounds like your device might be underpowered. what kind of device are you using, what version of Android do you have installed, and how much free space do you have left on your device?

Samsung Galaxy A12, Android Version 10. memory 81% of 32GB occupied, 5.8GB available. SD card 5GB of 29.5GB occupied, 24.5GB available.

I don’t do much on android anymore, but I’m wondering if you can download the .apk from the play store on your PC and side load it? (throw the app on the SD card and install it from there, local to the device)

You can also log on to the play store from the web and push previously ‘purchased’ software to any registered device to your profile.

I don’t see any obvious blockers. You might want to contact Google or Samsung, though - we don’t have any control over installation of the app aside from saying which devices/OS versions it’s compatiable with.

Did try again and again, but did not change the phone (no deleting of files or apps). Yesterday it finally worked and the download completed… was maybe just a bandwidth / connection problem.

… iNat seems to be optimized to first world bandwith and connection quality. Still remember the time in Haiti when uploading a single observation took 10 minutes or longer…