App won't stop crashing

Platform: Android

App version number: 1.21.15

Description of problem: This is a problem I’ve been encountering for the last couple of months and because of it, I’ve neglected the use of iNat through mobile. The app constantly crashes before I can do anything with the pop-up saying iNat isn’t working. Sometimes, it will work, such as today’s outing where I made 40-ish obs but I was out of cell service and now I’ve been working the last two hours trying to get the blasted app to sync it to the internet, but the closest I’ve gotten is the green bar on top saying “Preparing” before it crashes.

Solutions I’ve tried: 1. Restart my phone. 2. Updated the app, but it seems to make the app run slower. Any other ideas?

2 Likes

To be honest, the iNat app has never worked for me and I assume that’s because I tend to use older phones. I get that same message, over and over again. Sometimes giving up and coming back the next day seems to help.

1 Like

I’ve had similar issues. Not sure exactly what fixes it, but I usually clear the cache for the app or uninstall/reinstall. I can usually tell there are issues if iNat is taking up a large amount of storage space on my phone. Hope that helps!

I get the same error. May be a dumb suggestion, but have you tried clicking Wait? That’s actually been solving the issue for me lately. The error message just goes away as if nothing happened and I can continue doing whatever it is that I was doing.

If you upload tons of observations at once from your not-so-fast phone, it won’t respond well. Upload a few at a time, or just use the website. Also, this isn’t crashing, it’s just telling you that it’s taking a while to read the packets you’re sending it.

2 Likes

Welcome to the forum @renekimray & @chiarraicrax!

1 Like

@birdwhisperer @renekimray @chiarraicrax It can be super helpful to send log files to the developers so they can review more detail to help solve the issue. To send them a log file, right after the issue occurs, go to the About page in the app and tap 3 times on the version number. You will then have the option to email the log file to help@inaturalist.org. On my phone I then have to tap the text that says “Send debug logs from start date”, then select my email app from the list.

4 Likes

Enough room available on the phone?
Did you logout/login?

1 Like

Mine only does that when opening gerald.
Seriously, don’t click on it.

1 Like

I honestly don’t think device is the problem. My phone is only a year and a half old and is exceptionally faster than the computer I’m using right now. Also considering that all other apps I use, mostly nature or citizen science apps, read just fine, I believe it to be an app issue. Additionally, I often use another device which rightly belongs to another in my family and it’s a 3 year old phone. It does iNat observations in chunks just fine.

I just tried that. App runs faster now and more efficiently but it doesn’t start preparations for syncing the observations until I refresh the page and then it proceeds to crashes again.

Usually that works in the past but in this particular case, the app will close before it even lets me press a button. Hard to believe but I’m lucky to get that screenshot because the duration of the pop-up hardly last a second.

Which device do you have?

LG Stylo 5

1 Like