iOS App Crashes

Mine has been doing the same thing. Just crashes at random.

Logging out and back in seems to have solved the problem for me.

1 Like

Still doing the same thing. Loading and crashing.

For anyone still experiencing this problem, does deleting the app and reinstalling it resolve the issue? Sometimes I encountered this with beta versions, but deleting and reinstalling always stopped the crashes.

1 Like

I deleted and reinstalled, it seems to have fixed things. Before, I could crash it in less than a minute, every time. Now, it hasn’t crashed yet, but I’ve only been using it for a few minutes. But things that were guaranteed to crash it before haven’t crashed it, yet

1 Like

I’m having nearly constant issues with the app freezing (usually) or crashing (rarely). Normally this happens soon after I open the app and especially if I start scrolling through my observations. It’s gotten particularly bad since the last update, to the point where it freezes nearly every time I open the app and try to scroll through observations. Photo/observation upload seems to be working ok.

iPhone 6s, iOS 13.7, iNat app v 3.0.1, build 601

Hi @henicorhina, sorry you’re experiencing this - it happened to me too when I updated to 3.0. Does deleting and reinstalling the app fix the issue for you?

@bouteloua It’s not, unfortunately. I tried deleting and reinstalling twice, and also logged out and logged back in. Didn’t make any difference.

1 Like

Shoot. Thanks for following up! Hopefully they can get it figured out soon.

Are you going down the list of observations in the Me tab when it freezes/crashes, or are you looking through photos in individual observations or taxa? Sorry it’s still giving you trouble! More fixes are in the works.

Mostly when scrolling through observations in the Me tab. It does freeze to a lesser extent when looking through photos in individual observations, though mostly under my own observations in the Me tab. Everything in the Explore tab seems to be working ok.

1 Like

I came here to mention I’d been having the same issue, but deleting and reinstalling seems to have fixed the issue for me. I didn’t post it as a bug because I’d been too lazy to delete and reinstall until now.


I see it pause for like 2 seconds when scrolling through observations in my Me tab, at least the first time I log in. I suspect what’s happening here is that the app is loading more observations as you scroll, and that can make it freeze/pause momentarily. Once I scroll all the way to the bottom and load all the observations the app will load, scrolling on that tab is fine, probably because the observations are all cached in the app now.

I’ve got an iPhone XS, though, I’m wondering if your 6S is maybe running out of RAM or something?

That could be the case, but it’s odd that it only started happening after the last update, which makes me think that it has something to do with the app. I’m not sure that I could scroll down to the “bottom” of the Me tab, given the number of observations that I’ve uploaded. It would just take too long.

Version 3.0 is based on entirely new underlying code, so it’s a big change. The app might be doing something differently here that’s causing the problem. We’re working on version 3.0.2 with some more fixes, hoping that will be out in a few days.

My understanding is that the app loads your 200 most recent observations when you log in. However, as you use the app it starts caching new observations, as well as observations you’ve clicked on in the Activity tab, which causes the list on your Me tab to grow. I personally rarely use the app day to day and I’m constantly logging out and deleting and reinstalling it for troubleshooting and testing purposes, so it never has a chance too big on my phone. If you use the app a lot, more observations and info will be cached until you log out and log back in.

OK, I got some clarity from Alex, which is probably what I should have done first. ;-)

The issues with loading observations while scrolling likely stem from the fact that the app now uses a different API (node vs rails) than it used to. The takeaway is that the responses from node API are bigger, which can cause the loading issues in the Me tab. We don’t think this is causing the app to crash. We’re investigating ways to improve this.

There’s also some weirdness when scrolling down the Activity tab, we’re looking into that as well.

For those experiencing “freezing”, can you please describe exactly what you mean? Like I said before, if I’m scrolling down it will pause for like a second or two, and then I can continue to scroll and that’s pretty much it. Here’s a video of what that looks like in the Me tab, as well as much more disruptive loading in the Activity tab for me. This is all right after I log in to the app. The activity tab is definitely worse. I’m on very fast wifi, using an iPhone XS.

1 Like

2 posts were merged into an existing topic: iOS app has been frozen on “Updating database” for the past 24+ hours

I’ve encountered freezing and crashing problem after upgraded to the latest version. The “freezing” situation usually happens when I

  1. Press “Me” tab and try to tap each observation
  2. Press each tab, such as “Explore”, “Observe” and “Others”, it takes very long time to response and then crashed
  3. Try to select photos from camera rolls and freezing
  4. Tap “Settings”, then crashed again

I tried to reboot, and it became better, but when I pressed “Explore” and “Observer”, it still crashed.
So I just deleted it and reinstall app, then everything goes smoothly!

(However, thanks for fixing the multi-selection bug in camera rolls)

iOS 14.0 (iPhone 8), iNat version: 3.0.1 build 601


@mutolisp you didn’t log out of the app or delete the app since you updated it, correct? So the cache is still probably pretty large?

Also, just a heads up that version 3.0.2 is now live in the App Store. I’m not sure it will address all of the problems in this discussion, but it does have some crash fixes.

I have an iPhone 11. I was having issues and deleted the app, reinstalled, signed back in, and am still having them. When I ‘agreed’ on sambiology’s post, it didn’t show that I had agreed. I hit agree again like a lot, and finally after about 5 mins all of my agrees showed up. Same for comments. And my observations freeze when I try to look at them. And the explore button freezes.