iOS app has been frozen on "Updating database" for the past 24+ hours

Mine was doing the same and just now finally loaded.

Has been happening to me too. I deleted and reinstalled the app, the fix worked for me.

I just reinstalled the app. It was at a very high cache level (9 GB) anyway, so I needed to clean it out.

Same here!

Hi nightjar,

Ugh, I’m sorry that it’s taking so long to update the database. This version of the app moves from one database architecture to another, in order to let us start using Swift and modern language features in the app. When the app first launches after the update, it has to convert every single observation on the phone to the new format. It looks like for some reason that’s taking way too long on your phone, I’m not sure why.

Can you double check how much free space is on your phone, and how much space iNaturalist is using? You can check this by going to iPhone settings, choosing General, then choosing iPhone Storage. At the top you will see total and free iPhone storage, and then if you scroll down a little bit you will find a list of apps along with the amount of storage they’re using. Please find iNaturalist there and report back.

Also, if you have a lot of un-uploaded observations and you’re willing to help out with the beta program, please email me at alex@inaturalist.org. I can also try putting together a custom beta build just for you that will migrate your un-uploaded observations, so that you can upload them. After that you can delete & re-install from the app store, which will start fresh with a new database and download your observations from inaturalist.org.

Again, apologies for the difficulties with this!

Best wishes,
alex

4 Likes

I just launched iNat on my iPhone XS for the first time in a while (usually I use the web UI), and it went into a long “Updating database…” screen. Then the app crashed. I started it again, which brought me to the Me page, and a few moments later the app crashed again (without any scrolling). I tried again, it seemed stable, I scrolled down a few times, then it crashed again. I wanted to find the version number, and guessed that it was under the gear icon, so I tapped that, which showed me the top of the list of settings, but wouldn’t let me scroll down. I realized that the UI was hung, and then the app crashed again. So yes, indeed it is currently quite crashy.

On my next attempt I managed to scroll down on the settings page to find the version number and associated info, which is:

3.0.1, build 601. SDImageCache: 443,751 for 44 files - Un-Uploaded Photos: 3,504,807,277 for 1,163 files.

2 Likes

Same here. Same version and build. Same behavior, many crashes. On iPadOS 14.0.1 and iOS 14.0.1.

1 Like

@sullivanribbit @jbecky I moved your comments to this thread, which I think addresses the specific issue you’re experiencing.

2 Likes

My iPhone says iNat app uses 2.12 GB. Seems like a lot … it’s the 2nd-most storage-hungry app on my phone.

iPhone 7, iOS 13.7.

Yeah, there are some inefficiencies with how we don’t always clean up image storage that I plan to fix, but right now I’m mainly concerned with stability and getting users migrated to the new database successfully. Sorry that it took too long but I’m glad that it updated for you.

5 Likes

@alex, at the bottom of the Settings screen, where it shows a very large number with no units (bytes?) for “Un-Uploaded Photos” and a file count: what does this mean? “Un-Uploaded Photos” sounds to me like photos that have been taken on the phone with the iNaturalist app but not yet uploaded to the iNaturalist server, but I have zero photos meeting that definition, and apparently “1,163 files” worth of “Un-Uploaded Photos”.

1 Like

So is the best course of action to delete and re-install the app? Mine has been hung up for 48 hours. It never finishes updating the database and eventually crashes.

I have version 3.0.1 on an iPhone 6 running ios 12.4.6. The app is only using 66mb.

Update: I deleted and re-installed the app and it’s working again.

5 Likes

I had to delete and reload the app. I thought it had updated okay but the ability to use the app to add new records wasn’t working and kept bouncing me out. I think the reloaded app is functional.

My phone says the reloaded app is using only ~34 MB.

2 Likes

I updated to 3.0.2. It’s better but still crashes. I was able to create observations using the app and can usually refresh and view but not always. That’s better than before, when it crashed about 80% of the time just scrolling through my list.

1 Like

mine’s still hanging. I was out of it sick Thursday/Friday, but I’m fairly sure it worked the last time I tried to log in on Thursday. Hasn’t worked since. iOS14 on an original SE

Release 3.0.3 is just finishing beta testing today and hopefully will be approved by apple and ready to go tomorrow or Monday. Based on our internal testing it drastically speeds up this migration process and doesn’t get stuck or hang during the migration. I’ll post here once it’s generally available.

Thanks for your patience everyone. I know this transition is irritating but I know that once we get past it the iOS app experience will get a lot better.

5 Likes

I uninstalled/reinstalled and that fixed.

I’m actually strongly looking at an android phone next (I like my headphone jack dangit). How’s the app working on that OS?

1 Like

Our Android app is ahead of our iOS app by a number of features, mostly due to the fact that I as the iOS developer split my time, also doing our computer vision work.

My plan is that after getting past this database migration, I’ll be able to take advantage of a bunch of new swift libraries. Over the next year or so, iOS should be able to catch up to where Android is.

6 Likes

Thanks for helping me figure out what to do. Will delete and reload, cause three days is too long to wait for the database to update!

2 Likes

Just want to say that we’re lucky to have Alex doing incredibly complicated work on computer vision as well as working on the iOS app, the underlying code of which had to be rewritten piece by piece while still being functional.

6 Likes