iPhone syncing problem with iNatNZ

Strangely,using the samelatest iOS on my iPhone, and the latest update of iNat (lastweek was it,or this week) I can now add asmanyphotos as I like. But I can’t upload them, until I get home when they become able to “synch” and upload from th e phone ok.

The upload starts, but immediately asks me if I wish to Sign Up (not log in) to iNat, and will not stop asking. I tried signing in with google but couldn’t remember my password, if I have one(still don’t know if I have one, as I signedup to iNat from home on my desktop).

Once or twice Imust have succeeded in “logging in” because I got the message “User is already authenticated”. Still wouldn’t finish the upload.

It may be that it is uploading anyway, just taking a long time, and that is why it seems I can upload on my iPhone from home.

Sorry this isn’t very coherent, I am too tired to work through it again as my priority is uploading older observations from my desktop, which works fine, but thought i’d mention it.

Hi @kaipatiki_naturewatc

Ugh, so sorry, this is something we’ve seen off and on for a while now. Sometimes it’s related to a timezone issue, can you make sure the time on your iPhone isn’t too far off from correct?

Also, can you please post a screenshot of the alert that you see, if you see it again? Sometimes there’s some debug information in there that might be helpful for us to track this down.


Thanks Alex, thats good to know. I mean, at least it’s not just me:0. The time on my phone is correct, as it is displayed anyway. I just switched it to 24 hr clock, in case that helps:)

I just asked siri how to take a screen shot and her leads were not helpful, but I will try to pursue that. I think I sawinstructions on screen shots somewhere ,maybe in the top of the Bug reports category. I will look for it.

no success, the instructions in the link in the Bug report Read-First thread are the same. It doesnt work and if I keep the Sleep button pressed down my phone just offers to switch itself off.


"Join iNaturalist NZ?
New Zealand is part of the international …localinstritutions?

iNat NZlogo


If I press oK I get

Sign Up


Forgot password?

(check mark in a circle) Yes, licence mydata so scienntists…

green bar containing "Sign Up"thensome overwritten text…
"You must be (illegible)…raist.org

-JWT 2019-11-13 19:07:03 +0000

Or log inwith:
(logos/buttons for Fb and Google)By usingiNaturalist you agree…

That’s that one

@kaipatiki_naturewatc can you confirm:

  1. The current version of your iPhone app
  2. Which iPhone model you have
  3. Which version of iOS you have

To take a screen shot, you need to press two buttons at once. Did you try watching the demonstration video here?

Note: I’ve moved this to its own thread since it’s a different issue than reported in the original thread.

iPhone SE MP852X/A
iOS V.13.1.3
iNat V.2.8.4, build 549

I pressed the buttons together, initially using what I think of as the “Sleep” button, ie the one n the top, used to put it to sleep or wake it up.
Then after watching the video I tried it using the round “Home” button.

Nothing happened with either.

Thanks Carrie


There are iPhone SE specific instructions for taking screenshots here:

Thanks for your patience and help!


Thanks Alex. The video was worded slightly differently, ie press the buttons together (not one and hold, the the other), and seemed to work - ie I heard the camera shoot - but I can’t find the photos. Tried connecting phone to my iMac which is “dangerous” as Photos then wants to do all sorts of things, and iTunes fires up and threatens to “synch”, which is the last thing I want - at present I file all my photos in folders and know where they are. Duplicates are a big problem

So then I tried transferring images from phone to MacMini in my usual way, by Airdrop, and no screenshots were among the photos available for selection.

I no longer have an upload pending to test with, as the last one o my phone synched successfully while I was trying to find the screenshots.

Sorry, I will have to abandon this for now. If you have any more advice feel free to suggest, and if I have time I will try it.

Hi @kaipatiki_naturewatc,

I believe we have fixed this bug in the latest version of iNaturalist for iOS, could you please update the iNaturalist app on your iPhone to the most recent version and try again?

Thank you, and happy holidays,

Yes thanks Alex, the log in problem was fixed with the latest update. I reported on another thread, sorry i forgot to do so here

1 Like

Awesome, so glad to hear that.